Results 1 to 9 of 9

Thread: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

  1. #1
    Join Date
    Jan 2013
    Beans
    3

    Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    I recently received a monitor to use with my Ubuntu 12.10 laptop and I am running into a series of problems when it comes to connecting it with my laptop.

    http://imgur.com/a/ehq9o

    I have a Lenovo G460 Laptop with an nVidia GeForce 310M and the main problem is that when I plug in my monitor and boot up my computer, the nVidia xServer settings default to scheme with my laptop screen overlaid on my monitor. (Pictured at top of album)

    I can fix this problem by going to my nVidia settings and disabling the overlaid monitor. (Pictured at bottom of album)

    The main problem is that when I click "save to configuration file" it doesn't work past the next log-off/reboot, and defaults back to the "overlaid" setup.

    I have tried taking the config from the nVidia application, and editing the xorg.conf from the terminal manually, but it still doesn't work properly.

    Thanks!

  2. #2
    Join Date
    Apr 2008
    Location
    Australian in Germany
    Beans
    4,010
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    Do you get any error messages when you save the config in nVidia settings? Were you using gedit with sudo to change the xorg.config file?

    The point of the question is to find out if the xorg.conf file is not being saved properly, or not being read. I expect the former, because, as far as I know, the system will read an xorg.conf file if there is one there. I hope that hasn't changed. I run dual monitors too...

    Perhaps you could post the contents of your xorg.conf file here so we can have a look at it.
    Please use the button marked # to put the text between code tags. They look like this [CODE] and the text goes here [/CODE]
    Michael

  3. #3
    Join Date
    Jan 2013
    Beans
    3

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    I don't get any errors when I save the config from the nVidia app.

    When I did the manual edit I did sudo Vim, and it seemed to save properly.

    Here is the current code:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 310M"
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1280x960 +0+0; CRT: 1280x960_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_56 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

    Here is the desired code:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 310M"
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "CRT: nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT: nvidia-auto-select +0+0; CRT: 1680x1050 +0+0; CRT: 1680x1050_60 +0+0; CRT: 1280x1024 +0+0; CRT: 1280x1024_75 +0+0; CRT: 1280x1024_60 +0+0; CRT: 1280x960 +0+0; CRT: 1280x960_60 +0+0; CRT: 1152x864 +0+0; CRT: 1152x864_75 +0+0; CRT: 1024x768 +0+0; CRT: 1024x768_75 +0+0; CRT: 1024x768_70 +0+0; CRT: 1024x768_60 +0+0; CRT: 800x600 +0+0; CRT: 800x600_75 +0+0; CRT: 800x600_72 +0+0; CRT: 800x600_60 +0+0; CRT: 800x600_56 +0+0; CRT: 640x480 +0+0; CRT: 640x480_75 +0+0; CRT: 640x480_72 +0+0; CRT: 640x480_60 +0+0; CRT: nvidia-auto-select +0+0; CRT: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Thanks for helping!

  4. #4
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    I haven't dug into for a while, but xorg.conf really disapeared a few releases ago. Instead, there are a series of files to update as needed, and I suspect your changes need to go in one of them, as they are probably overriding xorg.conf. I believe these files are located in the /etc/X11/session/session.d folder. Someone else here may be able to help you more with that before I get a chance to re-read all of it again.

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,964
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    In Kubuntu 12.04, the NVIDIA settings manager pops up an authorization box when you try to save xorg.conf to its standard location in /etc/X11. That wasn't always true in earlier versions, though. As a workaround, you can save the file to your home directory from within the application, then copy it to /etc/X11 from a terminal using sudo.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    Quote Originally Posted by antsankov View Post
    I recently received a monitor to use with my Ubuntu 12.10 laptop and I am running into a series of problems when it comes to connecting it with my laptop.

    http://imgur.com/a/ehq9o

    I have a Lenovo G460 Laptop with an nVidia GeForce 310M and the main problem is that when I plug in my monitor and boot up my computer, the nVidia xServer settings default to scheme with my laptop screen overlaid on my monitor. (Pictured at top of album)

    I can fix this problem by going to my nVidia settings and disabling the overlaid monitor. (Pictured at bottom of album)

    The main problem is that when I click "save to configuration file" it doesn't work past the next log-off/reboot, and defaults back to the "overlaid" setup.

    I have tried taking the config from the nVidia application, and editing the xorg.conf from the terminal manually, but it still doesn't work properly.

    Thanks!
    When you do the save in the nVidia settings manager, the save (at least for me) tells you where it is going to save it to, and asks for the administrator password to do the update, so I don't think the permissions are a problem (as suggested by the post saying to copy to your folder then use the command line to copy it to appropriate system folder). You should be sure the path that it shows for where it is saving the file is correct.

    After you do the save in nVidia settings manager, exit it, then do:

    gedit /etc/X11/xorg.conf

    and see if it looks the way you think it should. You won't be able to save changes from there unless you precede it with "sudo ".

    I'm still not convinced this is the way to go. I would think in the long run you'd be better off changing the appropriate file in the folder I mentioned before.

    But.....try the above and see if the actual xorg.conf file itself was changed right after the save, before rebooting, and using gedit NOT the nVidia settings manager to view it.

  7. #7
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    12,964
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    Quote Originally Posted by squakie View Post
    When you do the save in the nVidia settings manager, the save (at least for me) tells you where it is going to save it to, and asks for the administrator password to do the update
    That was not the case in earlier versions of Kubuntu that I have used. There was no prompt for the administrator password. I don't remember when it changed, but I'm pretty sure 10.04 did not prompt.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  8. #8
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    I don't know either - I just walked through the process in the nVidia settings manager to test on my PC using 12.10. I have a GTS 450 and hadn't really used nVidia settings manager since I first installed. On my system it did ask for a password (you may have to do the "try" button to get it to come up - otherwise I don't know if the nVidia settings manager has permissions for that folder or not (I would have thought it had to).

    I don't know anything otherwise - just what I tried here.


    EDIT: Just tried again: opened nVidia settings manager, clicked on Xserver Display Configuration, then clicked "save" - it first came up saying it couldn't access /etc/X11/xorg.conf, I clicked OK and then it asked for my password and saved the file.

    Don't know if that's of any help to anyone or not.
    Last edited by squakie; January 26th, 2013 at 01:13 AM.

  9. #9
    Join Date
    Jan 2013
    Beans
    3

    Re: Problems Saving nVidia xorg.conf for Laptop/Monitor Configuration

    Problem solved guys: I dropped the nVidia driver and I switched it out with the Open Source version. Since I don't game, I am willing to sacrifice performance for usability.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •