Results 1 to 6 of 6

Thread: eeePC 1015PEM Unclaimed - wireless not working

  1. #1
    Join Date
    Dec 2012

    eeePC 1015PEM Unclaimed - wireless not working


    I have upgraded from Ubuntu 10 to 12.10. The wireless stopped working, so I did a clean install. I have tried a few fixes, but none have worked. It used to see wireless networks, but wouldn't log in.

    I would appreciate any help.

    Using the terminal, I came up with the following.

    sudo lshw -C network

    *-network UNCLAIMED
    description: Network controller
    product: BCM4313 802.11b/g/n Wireless LAN Controller
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:02:00.0
    version: 01
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: latency=0
    resources: memory:fbffc000-fbffffff
    description: Ethernet interface
    product: AR8132 Fast Ethernet
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:01:00.0
    logical name: eth0
    version: c0
    serial: 20:cf:30:43:0f:fc
    size: 100Mbit/s
    capacity: 100Mbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
    resources: irq:46 memory:f7fc0000-f7ffffff ioport:ec00(size=128)


    eth0 no wireless extensions.

    lo no wireless extensions.

    cat /etc/lsb-release; uname -a

    DISTRIB_DESCRIPTION="Ubuntu 12.10"
    Linux alex-1015PEM 3.5.0-19-generic #30-Ubuntu SMP Tue Nov 13 17:48:01 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    alex@alex-1015PEM:~$ lspci -nnk | grep -iA2 net
    01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8132 Fast Ethernet [1969:1062] (rev c0)
    Subsystem: ASUSTeK Computer Inc. Device [1043:838a]
    Kernel driver in use: atl1c
    02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: AzureWave Device [1a3b:2047]
    Kernel modules: bcma


    eth0 Link encap:Ethernet HWaddr 20:cf:30:43:0f:fc
    inet addr: Bcast: Mask:
    inet6 addr: fe80::22cf:30ff:fe43:ffc/64 Scope:Link
    RX packets:58497 errors:2 dropped:0 overruns:0 frame:1
    TX packets:34729 errors:0 dropped:0 overruns:0 carrier:7
    collisions:0 txqueuelen:1000
    RX bytes:77470907 (77.4 MB) TX bytes:3474675 (3.4 MB)

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2063 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2063 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:223052 (223.0 KB) TX bytes:223052 (223.0 KB)

  2. #2
    Join Date
    Mar 2011
    19th Hole
    Ubuntu 16.04 Xenial Xerus

    Re: eeePC 1015PEM Unclaimed - wireless not working

    You've supplied an admirable amount of info. Well done. Lots to work with.

    Your problem is probably an old one dealing with the broadcom chipset. Instructions for solving it can be found here. Read thoroughly before proceeding because the page is dense with instructions and covers many different broadcom chipsets. You can ignore the other chipsets and focus on the instructions dealing with the 4313. The 4313 shouldn't be too bad because it is relatively newer. My broadcom chipsets are on older Dell laptops and harder to solve. According to the referenced page, your chipset uses the brcmsmac/brcm80211 module which was merged into the kernel way back at 2.6.37. This was probably why it worked right out of the box on your 10.x installs. Don't know if this module was dropped in 12.10. You should be able to get functionality back by following the instructions on the referenced page (including following the contained links) and reinstalling brcmsmac/brcm80211. After this is done, check with:

    lsmod | grep brcm

  3. #3
    Join Date
    Dec 2012

    Re: eeePC 1015PEM Unclaimed - wireless not working

    I went through that page & it looked like I should use the wl Proprietary Broadcom STA Wireless driver. 12.10 (Quantal Quetzal)

    At the end I got.

    sudo modprobe wl
    FATAL: Module wl not found.

    There was no reply to your code.
    lsmod | grep brcm

    I am still getting.
    sudo lshw -C network
    *-network UNCLAIMED

    Any suggestions?

  4. #4
    Join Date
    Mar 2011
    19th Hole
    Ubuntu 16.04 Xenial Xerus

    Re: eeePC 1015PEM Unclaimed - wireless not working

    Quote Originally Posted by v4bes View Post
    I went through that page & it looked like I should use the wl Proprietary Broadcom STA Wireless driver. 12.10 (Quantal Quetzal)
    Correct. Specifically, this section.

    At the end I got.

    sudo modprobe wl
    FATAL: Module wl not found.
    Please describe completely the steps you took. Should be as follows:

    1. Make sure you have activated "restricted" repository. If you do not have access to "restricted" repository, package won't download.
    2. Open a terminal. Do:

    sudo apt-get update
    You will be asked for your password. While typing it in, nothing will show on the screen--not even ****. This is normal. apt will then update.

    3. Then:

    sudo apt-get install bcmwl-kernel-source
    You should be getting either a screen full of scrolling actions, or a question asking if you want to go ahead and install the package. Type Y. If this step generates error, please post it back to this thread between the [CODE][\CODE] markers (substituting / for \) for easier readability).

    4. Then:

    sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma clean out all modules for fresh start,

    5. Then, try again:

    sudo modprobe wl
    If same error, do:

    lsmod itself, and post whole output back to this thread.

    There was no reply to your code.
    lsmod | grep brcm

    I am still getting.
    sudo lshw -C network
    *-network UNCLAIMED
    Because module wl did not load, my subsequent command will indeed not return anything, nor will your network be "claimed". Other steps also possible, but let's do these for now.

  5. #5
    Join Date
    Dec 2012

    Re: eeePC 1015PEM Unclaimed - wireless not working

    Delayed by holidays. I did do those steps before, but here is they are again.

    sudo apt-get update
    [sudo] password for alex:
    Ign quantal-security InRelease
    Ign quantal InRelease
    Ign quantal InRelease
    Ign quantal-updates InRelease
    Ign quantal-backports InRelease
    Hit quantal Release.gpg
    Get:1 quantal-security Release.gpg [933 B]
    Get:2 quantal Release.gpg [72 B]
    Get:3 quantal-updates Release.gpg [933 B]
    Hit quantal Release
    Get:4 quantal-security Release [49.6 kB]
    Get:5 quantal-backports Release.gpg [933 B]
    Hit quantal Release
    Hit quantal/main Sources
    Get:6 quantal-updates Release [49.6 kB]
    Hit quantal/main amd64 Packages
    Get:7 quantal-security/main Sources [22.4 kB]
    Hit quantal/main i386 Packages
    Get:8 quantal-backports Release [49.6 kB]
    Get:9 quantal-security/restricted Sources [14 B]
    Get:10 quantal-security/universe Sources [9,109 B]
    Get:11 quantal-security/multiverse Sources [699 B]
    Hit quantal/main Sources
    Get:12 quantal-security/main amd64 Packages [62.2 kB]
    Hit quantal/restricted Sources
    Ign quantal/main Translation-en_CA
    Hit quantal/universe Sources
    Ign quantal/main Translation-en
    Hit quantal/multiverse Sources
    Hit quantal/main amd64 Packages
    Hit quantal/restricted amd64 Packages
    Hit quantal/universe amd64 Packages
    Hit quantal/multiverse amd64 Packages
    Get:13 quantal-security/restricted amd64 Packages [14 B]
    Get:14 quantal-security/universe amd64 Packages [22.2 kB]
    Hit quantal/main i386 Packages
    Hit quantal/restricted i386 Packages
    Get:15 quantal-security/multiverse amd64 Packages [1,150 B]
    Hit quantal/universe i386 Packages
    Get:16 quantal-security/main i386 Packages [61.8 kB]
    Hit quantal/multiverse i386 Packages
    Hit quantal/main Translation-en_CA
    Hit quantal/main Translation-en
    Get:17 quantal-security/restricted i386 Packages [14 B]
    Hit quantal/multiverse Translation-en
    Get:18 quantal-security/universe i386 Packages [22.9 kB]
    Hit quantal/restricted Translation-en
    Get:19 quantal-security/multiverse i386 Packages [1,391 B]
    Hit quantal/universe Translation-en_CA
    Hit quantal/universe Translation-en
    Get:20 quantal-updates/main Sources [59.7 kB]
    Hit quantal-security/main Translation-en
    Get:21 quantal-updates/restricted Sources [889 B]
    Hit quantal-security/multiverse Translation-en
    Get:22 quantal-updates/universe Sources [65.9 kB]
    Hit quantal-security/restricted Translation-en
    Get:23 quantal-updates/multiverse Sources [2,934 B]
    Hit quantal-security/universe Translation-en
    Get:24 quantal-updates/main amd64 Packages [158 kB]
    Get:25 quantal-updates/restricted amd64 Packages [1,970 B]
    Get:26 quantal-updates/universe amd64 Packages [135 kB]
    Ign quantal-security/main Translation-en_CA
    Ign quantal-security/multiverse Translation-en_CA
    Ign quantal-security/restricted Translation-en_CA
    Ign quantal-security/universe Translation-en_CA
    Get:27 quantal-updates/multiverse amd64 Packages [7,936 B]
    Get:28 quantal-updates/main i386 Packages [158 kB]
    Get:29 quantal-updates/restricted i386 Packages [1,979 B]
    Get:30 quantal-updates/universe i386 Packages [136 kB]
    Get:31 quantal-updates/multiverse i386 Packages [8,106 B]
    Get:32 quantal-updates/main Translation-en [76.3 kB]
    Hit quantal-updates/multiverse Translation-en
    Hit quantal-updates/restricted Translation-en
    Get:33 quantal-updates/universe Translation-en [75.7 kB]
    Get:34 quantal-backports/main Sources [14 B]
    Get:35 quantal-backports/restricted Sources [14 B]
    Get:36 quantal-backports/universe Sources [4,597 B]
    Get:37 quantal-backports/multiverse Sources [14 B]
    Get:38 quantal-backports/main amd64 Packages [14 B]
    Get:39 quantal-backports/restricted amd64 Packages [14 B]
    Get:40 quantal-backports/universe amd64 Packages [4,748 B]
    Get:41 quantal-backports/multiverse amd64 Packages [14 B]
    Get:42 quantal-backports/main i386 Packages [14 B]
    Get:43 quantal-backports/restricted i386 Packages [14 B]
    Get:44 quantal-backports/universe i386 Packages [5,567 B]
    Get:45 quantal-backports/multiverse i386 Packages [14 B]
    Hit quantal-backports/main Translation-en
    Hit quantal-backports/multiverse Translation-en
    Hit quantal-backports/restricted Translation-en
    Get:46 quantal-backports/universe Translation-en [3,850 B]
    Ign quantal/multiverse Translation-en_CA
    Ign quantal/restricted Translation-en_CA
    Ign quantal-updates/main Translation-en_CA
    Ign quantal-updates/multiverse Translation-en_CA
    Ign quantal-updates/restricted Translation-en_CA
    Ign quantal-updates/universe Translation-en_CA
    Ign quantal-backports/main Translation-en_CA
    Ign quantal-backports/multiverse Translation-en_CA
    Ign quantal-backports/restricted Translation-en_CA
    Ign quantal-backports/universe Translation-en_CA
    Fetched 1,263 kB in 18s (69.3 kB/s)
    Reading package lists... Done

    alex@alex-1015PEM:~$ sudo apt-get install bcmwl-kernel-source
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    bcmwl-kernel-source is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.
    alex@alex-1015PEM:~$ sudo modprobe -r b43 ssb wl brcmfmac brcmsmac bcma
    FATAL: Module wl not found.

    alex@alex-1015PEM:~$ sudo modprobe wl
    FATAL: Module wl not found.

    alex@alex-1015PEM:~$ lsmod
    Module Size Used by
    btrfs 761721 0
    zlib_deflate 26914 1 btrfs
    libcrc32c 12644 1 btrfs
    ufs 74821 0
    qnx4 13317 0
    hfsplus 84442 0
    hfs 54553 0
    minix 36058 0
    ntfs 97304 0
    msdos 17332 0
    jfs 181093 0
    xfs 837979 0
    reiserfs 246392 0
    ext2 72880 0
    bnep 18140 2
    rfcomm 46619 0
    bluetooth 209199 10 bnep,rfcomm
    parport_pc 32688 0
    ppdev 17073 0
    joydev 17457 0
    snd_hda_codec_realtek 77876 1
    uvcvideo 76749 0
    snd_hda_intel 33491 3
    videobuf2_core 32851 1 uvcvideo
    videodev 120309 2 uvcvideo,videobuf2_core
    snd_hda_codec 134212 2 snd_hda_codec_realtek,snd_hda_intel
    videobuf2_vmalloc 12860 1 uvcvideo
    videobuf2_memops 13368 1 videobuf2_vmalloc
    snd_hwdep 13602 1 snd_hda_codec
    snd_pcm 96580 2 snd_hda_intel,snd_hda_codec
    i915 520629 3
    snd_seq_midi 13324 0
    snd_rawmidi 30512 1 snd_seq_midi
    snd_seq_midi_event 14899 1 snd_seq_midi
    snd_seq 61521 2 snd_seq_midi,snd_seq_midi_event
    snd_timer 29425 2 snd_pcm,snd_seq
    snd_seq_device 14497 3 snd_seq_midi,snd_rawmidi,snd_seq
    drm_kms_helper 46784 1 i915
    drm 275528 4 i915,drm_kms_helper
    snd 78734 15 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
    eeepc_wmi 13109 0
    asus_wmi 24088 1 eeepc_wmi
    sparse_keymap 13890 1 asus_wmi
    coretemp 13400 0
    psmouse 95552 0
    serio_raw 13215 0
    microcode 22803 0
    soundcore 15047 1 snd
    i2c_algo_bit 13413 1 i915
    lpc_ich 17061 0
    mac_hid 13205 0
    video 19335 1 i915
    wmi 19070 1 asus_wmi
    snd_page_alloc 18484 2 snd_hda_intel,snd_pcm
    lp 17759 0
    parport 46345 3 parport_pc,ppdev,lp
    hid_generic 12493 0
    usbhid 46947 0
    hid 100366 2 hid_generic,usbhid
    atl1c 41101 0

  6. #6
    Join Date
    Dec 2012

    Re: eeePC 1015PEM Unclaimed - wireless not working

    I am still looking for help with this problem. Any help would be appreciated.


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts