I have been getting this message with google chrome that "your profile could not be opened correctly". And none of my bookmark images showed up or anything. I did some searching and ended up completely uninstalling and re-installing google chrome and it seemed to be working fine. I then did a bunch of stuff and restarted my computer. When I got back on and launched chrome, I got a prompt that Default wanted a password for the keyring or something. I tried all my passwords and nothing worked. I ended up closing google chrome and exiting the keyring alert. I re-launched chrome and I then got the "your profile could not be opened correctly" message again with all the previous symptoms. I am now convinced the two problems are related. I tried searching on how to deal with this keyring problem and everywhere says to check the "available to all users" box in the network settings. Also I tried to do rm ~/.gnome2.keyrings/*keyring but apperently .gnome2/keyrings doesn't exist.

Any tips at all how to solve this problem?