Results 1 to 7 of 7

Thread: Ubuntu 12.04 booting into terminal

  1. #1
    Join Date
    Mar 2010

    Red face [SOLVED] Ubuntu 12.04 booting into terminal

    Hello Guys,

    After updating my pc with latest updates, when i restart my pc it is booting into terminal as below

    When enter "startx" command in the terminnal I am receiving below output:

    I am able to boot into Ubutnu using "Previous Linux versions".

    Please help what is the issue here?
    Last edited by nagubhai; January 19th, 2013 at 06:54 AM.

  2. #2
    Join Date
    Nov 2011

    Re: Ubuntu 12.04 booting into terminal

    Have you installed the nvidia drivers at some earlier date or are you using the open source ones ?

    You could try booting into the previous kernel if you have not removed it. Should be in your grub boot menu.

    If you have installed the binary nvidia drivers then you may want to remove them from command line and revert back to the open source ones as a test.
    I am on an ati card with the binary drivers and occasionally kernel updates can break things.

  3. #3
    Join Date
    May 2012

    Re: Ubuntu 12.04 booting into terminal

    I have had a similar issue on my 12.04 64-bit install. It doesn't happen all the time but sometimes when the machine is rebooted, it will boot into that first screen you posted where it displays the login at a terminal input. Instead of providing my credentials, I just hit enter and then it boots into the GUI like its supposed to. I'm not sure why it gets confused and does this as it doesn't appear to be negatively impacting anything its just kind of a nuisance.

    I am not experiencing the second screen you have posted though, sorry. Since I started using linux, it seems to be plagued with little issues like this that really detract from its overall appeal. Why can't these small issues get resolved so our machines just boot like its supposed to? Its not enough for me to quit using linux, its just annoying when simple things like, um, rebooting (a simple task) become another hurdle of just using the machine.

  4. #4
    Join Date
    Jun 2010
    London, England
    Ubuntu Development Release

    Re: Ubuntu 12.04 booting into terminal

    Ubuntu sits on top of the Linux kernel which uses a command line interface. So, first the kernel is loaded and then Ubuntu logs into the kernel in our name and then loads to a GUI log in screen. Most of the time this login to the kernel is hidden from view by a splash screen. I some times see the Linux message when I am running the Ubuntu development release. But I have never had the loading stop until I pressed enter.

    I also think that a lot of issues are caused by heavy modification of the OS. Lots of configuration scripts are run during the loading process. There can be conflicts that require more than one attempt to activate modules.

    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530

  5. #5
    Join Date
    Jan 2013

    Wink Re: Ubuntu 12.04 booting into terminal

    Whats happening here looks similar to what happens when you use the command ctrl + shift + F1. (could be ctrl + alt + F1). I don't know a quick way to fix your problem but if you burn a 12.10 cd and load it up it has an option to repair ubuntu or write over it. Just think about if your willing to do that.

  6. #6
    Join Date
    Jan 2013

    Re: Ubuntu 12.04 booting into terminal

    After yesterdays system update (which also updated some x-server components from what i remember) I had the same problem. System would boot into terminal.

    startx command gave me almost the same error:

    So i figured it must be because of then latest nvidia drivers I installed directly from nvidias website some time ago.

    Removing and then installing nvidia-current package solved this:
    sudo apt-get remove nvidia-current
    sudo apt-get install nvidia-current
    On the side note I had to boot into my Windows 7 partition to google this solution, a system that has never failed me. On the other hand I've had about a dozen problems with ubuntu 12.04 x64 since i got it 2 months ago. Often something would stop working for no apparent reason or after a system update and I have to google a fix. The only reason I havent send this system back to where it came from yet is because I like learning it. Go figure O_o
    Last edited by Kantstandya; January 19th, 2013 at 12:23 AM.

  7. #7
    Join Date
    Mar 2010

    Re: Ubuntu 12.04 booting into terminal

    Thanks for all responses.

    I resolved it myself. I don’t know what i did exactly to resolve this. Below are the actions which did:
    1. Removed NVIDIA drivers
    2.Tried to install drivers from UI. It failed.
    3.When I restart my PC, it asked for partial upgrade. I accepted it. Boom my UI is back


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts