Results 1 to 9 of 9

Thread: Updating Seems Impossible

  1. #1
    Join Date
    Mar 2007
    Location
    NY
    Beans
    476
    Distro
    Ubuntu 16.04 Xenial Xerus

    Updating Seems Impossible

    I'm having some issues updating.
    im getting errors:
    Code:
    W: GPG error: http://dl.google.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A040830F7FAC5991
    W: GPG error: http://moblock-deb.sourceforge.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CB53C4079072870B
    W: GPG error: http://wicd.longren.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FEC820F4B8C0755A
    W: GPG error: http://download.webmin.com sarge Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D97A3AE911F63C51
    W: GPG error: http://apt.wicd.net jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY FEC820F4B8C0755A
    W: GPG error: http://packages.medibuntu.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
    W: GPG error: http://download.virtualbox.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DCF9F87B6DFBCBAE
    W: GPG error: http://deb.opera.com sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 033431536A423791
    W: GPG error: http://repository.cairo-dock.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1392A97E41317877
    W: GPG error: http://debian.alphagemini.org unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7E5D69A103CA4243
    W: GPG error: http://www.debian-multimedia.org sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
    W: GPG error: http://wine.budgetdedicated.com jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 58403026387EE263
    W: GPG error: http://ubuntusatanic.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6D17A3829B1DB022
    W: GPG error: http://akirad.cinelerra.org akirad-jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DB70C672B219D801
    W: GPG error: http://ddebs.ubuntu.com jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ECDCAD72428D7C01
    W: GPG error: http://ddebs.ubuntu.com jaunty-updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ECDCAD72428D7C01
    W: GPG error: http://archive.getdeb.net jaunty-getdeb-testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8A515F046D7E7CF
    W: GPG error: http://philip.magicalforest.se jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A078FBD295CC1732
    W: GPG error: http://download.tuxfamily.org intrepid-upure64 Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5CEBE24C2C4C84CC
    W: GPG error: http://deb.opera.com sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 033431536A423791
    W: GPG error: http://deb.opera.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 033431536A423791
    W: GPG error: http://deb.opera.com testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 033431536A423791
    W: GPG error: http://deb.opera.com unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 033431536A423791
    W: GPG error: http://www.debian-multimedia.org lenny Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
    W: GPG error: http://www.debian-multimedia.org experimental Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
    W: GPG error: http://apt.last.fm debian Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A2F29191CA62DDDF
    W: GPG error: http://ddebs.ubuntu.com jaunty-proposed Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ECDCAD72428D7C01
    W: GPG error: http://ddebs.ubuntu.com jaunty-security Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ECDCAD72428D7C01
    W: GPG error: http://apt.schmidtke-hb.de jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5B638EFECEAE2DE7
    W: GPG error: http://snapshots.ekiga.net intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A0F6A0EC3596ED6E
    W: GPG error: http://download.tuxfamily.org ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 73E6B0FAA42A6CF5
    W: GPG error: http://archive.getdeb.net jaunty-getdeb Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A8A515F046D7E7CF
    W: GPG error: http://debian.cihar.com unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY E64A2AA53714DD6A
    W: GPG error: http://debian.scribus.net jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5BC4CFB8EEF818CF
    W: GPG error: http://mirror.noreply.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CFF71CB3AFA44BDD
    W: GPG error: http://debian.vakevainen.fi unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2BFAFC26585DECB0
    W: GPG error: http://weeklybuilds.mythbuntu.org jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C1A77650EEED06D0
    W: GPG error: http://packages.thinkgos.com painful Release: The following signatures were invalid: NODATA 1 NODATA 2
    W: GPG error: http://au.ubuntu.cafuego.net jaunty-cafuego Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 81600957AF425CB5
    W: GPG error: http://hydr0g3n.free.fr jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CA6F8234A08A9A43
    W: GPG error: http://ubuntu.geole.info jaunty Release: The following signatures were invalid: NODATA 1 NODATA 2
    W: GPG error: http://ubuntu.geole.info jaunty-backports Release: The following signatures were invalid: NODATA 1 NODATA 2
    W: GPG error: http://www.ilportalinux.it intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F8C271F85E94A954
    W: GPG error: http://www.vollstreckernet.de stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D63913EF50D0AE60
    W: GPG error: http://www.vollstreckernet.de testing Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D63913EF50D0AE60
    W: GPG error: ftp://ftp.berlios.de ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 074D737EED75F599
    W: GPG error: ftp://ftp.berlios.de ./ Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 074D737EED75F599
    W: GPG error: http://ppa.launchpad.net jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 60D4403E85361F10
    W: GPG error: http://ppa.launchpad.net jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1281ADAE04F71C22
    W: Failed to fetch http://ftp.xy.debian.org/debian/dists/experimental/Release.gpg  Could not resolve 'ftp.xy.debian.org'
    
    W: Failed to fetch http://ftp.xy.debian.org/debian/dists/experimental/main/i18n/Translation-en_US.bz2  Could not resolve 'ftp.xy.debian.org'
    
    W: Failed to fetch http://ubuntu.mi.hs-heilbronn.de/other/opendicom/./Release.gpg  Could not resolve 'ubuntu.mi.hs-heilbronn.de'
    
    W: Failed to fetch http://ubuntu.mi.hs-heilbronn.de/other/opendicom/./en_US.bz2  Could not resolve 'ubuntu.mi.hs-heilbronn.de'
    
    W: Failed to fetch http://apt.boxee.tv/dists/jaunty/main/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://download.skype.com/linux/repos/debian/dists/stable/non-free/binary-amd64/Packages  404 Not Found [IP: 204.9.165.83 80]
    
    W: Failed to fetch http://uk.weeklybuilds.mythbuntu.org/mythbuntu/ubuntu/dists/jaunty/main/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://apt.emesene.org/./Packages  404 Not Found
    
    W: Failed to fetch http://apt.emesene.org/./Sources  404 Not Found
    
    W: Failed to fetch http://GetSwiftFox.Com/builds/debian/branch/dists/unstable/non-free/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://www.prodeia.de/mms/intrepid/binary/Packages  404 Not Found
    
    W: Failed to fetch http://GetSwiftFox.Com/builds/debian/trunk/dists/unstable/non-free/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://packages.thinkgos.com/gos/dists/painful/main/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://packages.thinkgos.com/gos/dists/painful/main/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://mirror.ubuntulinux.nl/dists/jaunty-seveas/all/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://debian.zaubberer.net/repos/sid/./Packages  404 Not Found
    
    W: Failed to fetch http://mirror.ubuntulinux.nl/dists/jaunty-seveas/all/source/Sources  404 Not Found
    
    W: Failed to fetch http://UQM.Debian.Net/stable/Packages  404 Not Found
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty/universe/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty/multiverse/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty/universe/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty/multiverse/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://hydr0g3n.free.fr/ubuntu/dists/jaunty/main/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/main/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/restricted/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/universe/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/multiverse/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/main/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/restricted/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/universe/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://ubuntu.geole.info/dists/jaunty-backports/multiverse/source/Sources.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/amule/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://www.vollstreckernet.de/debian/dists/stable/wx/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://www.vollstreckernet.de/debian/dists/testing/amule/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://www.vollstreckernet.de/debian/dists/testing/wx/binary-amd64/Packages.bz2  Sub-process bzip2 returned an error code (2)
    
    W: Failed to fetch http://greenie.sk/ubuntu/dists/intrepid/e17/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://greenie.sk/ubuntu/dists/intrepid/opengeu/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/alessandro-ghersi/ppa/ubuntu/dists/jauntyd/main/source/Sources  404 Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/q-funk/ppa/ubuntu/dists/jaunty/main/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/q-funk/ppa/ubuntu/dists/jaunty/main/source/Sources  404 Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/ted-gould/ppa/ubuntu/dists/jaunty/main/binary-amd64/Packages  404 Not Found
    
    W: Failed to fetch http://ppa.launchpad.net/ted-gould/ppa/ubuntu/dists/jaunty/main/source/Sources  404 Not Found
    
    W: Some index files failed to download, they have been ignored, or old ones used instead.
    W: You may want to run apt-get update to correct these problems
    danny@danny-desktop:~/Desktop$ rm launchpad-ppa-fix.tar.gz launchpad-ppa-fix.pl
    danny@danny-desktop:~/Desktop$
    is there some kind of script that removes only those?(the bad ones?)
    what should i do?

  2. #2
    Join Date
    Apr 2009
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Updating Seems Impossible

    Oh my! You sure have a lot of third-party repositories. Unless you know why you have them, you should disable them at least. Either uncheck them in Software Sources, or edit /etc/apt/sources.list and comment them out with a # at the beginning of the lines. Better yet would be deleting them altogether.

    On the other hand, if you actually want them, you need to import the key for each one.

  3. #3
    Join Date
    Dec 2008
    Beans
    89
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Updating Seems Impossible

    Something seems to have happened to your keys. Regardless, you can/should get rid of some of those. For example, wicd is now in the vanilla repositories. Otherwise, you'll have to google each one of those plus the term "wget" (which should/will bring up instructions on how to re-add the keys).

  4. #4
    Join Date
    Mar 2007
    Location
    NY
    Beans
    476
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Updating Seems Impossible

    do i have to uncomment/remove them manually? or can i somehow use a script?

  5. #5
    Join Date
    Apr 2008
    Beans
    6

    Re: Updating Seems Impossible

    Try the following to clean up the old key and install new key:
    1) check the current key list
    sudo apt-key list
    Then you should be able to see the old key in the list. It looks something like

    pub 1024D/6A423791 2006-09-26 [expires: 2009-09-25]
    uid Opera Software Archive Automatic Signing Key <hostmaster@opera.com>

    2) remove the obsoleted key
    sudo apt-key del 6A423791
    Note that here 6A423791 is the key ID you find in step 1).

    3) install new key
    wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

    Then the key errors should be resolved.

  6. #6
    Join Date
    Oct 2009
    Location
    Somewher around the Earth
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Updating Seems Impossible

    Thanks webbertiger

    It helped me to solve same issue with Opera key expired.
    Regards

    CrazySat
    PER ASPERA AD ASTRA

  7. #7
    Join Date
    Jul 2010
    Beans
    6
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Updating Seems Impossible

    Quote Originally Posted by webbertiger View Post
    1) check the current key list
    sudo apt-key list
    Then you should be able to see the old key in the list. It looks something like

    pub 1024D/6A423791 2006-09-26 [expires: 2009-09-25]
    uid Opera Software Archive Automatic Signing Key <hostmaster@opera.com>

    2) remove the obsoleted key
    sudo apt-key del 6A423791
    Note that here 6A423791 is the key ID you find in step 1).

    3) install new key
    wget -O - http://deb.opera.com/archive.key | sudo apt-key add -

    Then the key errors should be resolved.

    Perfect! Restarted Update Manager and it worked without a hitch!

  8. #8
    Join Date
    May 2008
    Location
    /dev/null
    Beans
    216
    Distro
    Ubuntu

    Re: Updating Seems Impossible

    thanks

  9. #9
    Join Date
    Oct 2006
    Location
    Ayrshire.
    Beans
    50,675
    Distro
    Ubuntu Development Release

    Re: Updating Seems Impossible

    Old thread closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •