Sorry, Samiux. If you click on those, they are compressed .deb files.

Never mind.

I tried the page you gave, but I still get the same error with both Libre Office and Adobe.

I'll see if I can find answers on other forums. If I do, I'll post back here. If I understood Apparmor better, I guess I could find the answer.

In file abstractions/ubuntu-browsers.d/productivity, which is included into Firefox's profile, I spotted the following line:
Code:
/opt/Adobe/Reader9/bin/acroread Cxr -> sanitized_helper,
So it seems that Adobe is supposed to be permitted.

I tried with Firefox in Safe Mode, but still I get the problem.

I can only guess that there is something odd about my set-up. Sigh.