Results 1 to 10 of 16

Thread: lightdm login leads to a wrong environment

Hybrid View

  1. #1
    Join Date
    Jan 2013
    Beans
    2

    lightdm login leads to a wrong environment

    This login problem appeared this morning.

    My favorite environment is gnome-classic (with effects). I can't use it any longer !
    When I choose the environment on the login screen, here is what happens:

    When I choose===================> it logs
    --------------.................................................. .... ---------------
    Ubuntu======================> Unity 2D ou 3D (depends on ?)
    Ubuntu 2D===================> Unity 2D
    Gnome Classic (without effects) => OK. Gnome Classic (without effects)
    Gnome Classic================> Unity 2D

    weird !

    I then created another user and I can log in normally for this user, but it is impossible to do it for my main user.

    Here are the results of commands:

    ls /usr/share/xsessions
    -----------------------
    gnome-classic.desktop gnome-fallback.desktop ubuntu-2d.desktop
    gnome.desktop gnome-shell.desktop ubuntu.desktop

    cat /etc/lightdm/lightdm.conf
    -----------------------------
    [SeatDefaults]
    user-session=ubuntu
    greeter-session=unity-greeter
    autologin-user=

    cat ~/.dmrc
    ------
    [Desktop]
    Session=gnome-fallback

    cat OtherUser/.dmrc
    ---------------
    [Desktop]
    Session=gnome-classic

    cat '/var/lib/AccountsService/users/boss'
    -----------------------------------------
    [User]
    XSession=gnome-fallback
    XKeyboardLayouts=
    Background=/usr/share/backgrounds/Twilight_Frost_by_Phil_Jackson.jpg

    I tried to replace "gnome-fallback" by "gnome-classic" in ~/.dmrc and '/var/lib/AccountsService/users/boss', but it returns to gnome-fallback.

    What can I do ?
    Last edited by Seagul; January 15th, 2013 at 11:45 PM.

  2. #2
    Join Date
    Dec 2007
    Beans
    518

    Re: lightdm login leads to a wrong environment

    I have an almost identical problem, except that everything ends in Gnome Classic (without effects). This happens in versions 12.4 and 12.10.

    lightdm.conf settings seem to make no difference.

    One clue, though. I select a desktop, but the setting doesn't stick. If I go back and check the selection before entering a password, it defaults to Ubuntu, no matter what I have selected. The only exception is if I am already logged on, in which case it defaults to Gnome Classic (without effects), which is what I am already logged on to.

  3. #3
    Join Date
    Dec 2007
    Beans
    518

    Re: lightdm login leads to a wrong environment

    This is bug 1052453, which is supposed to be fixed but evidently is not.

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: lightdm login leads to a wrong environment

    @Seagul

    Sure sounds like you been hit with the bug, but I notice that /etc/lightdm/lightdm.conf is set to user-session=ubuntu.

    Won't make any difference if its the bug.

    I would think you could install "gdm" and use it as a work-a-round untill this bug in lightdm gets fixed.

    Code:
    sudo apt-get install gdm
    It should ask you during or after the install if you want gdm or lightdm as default.

  5. #5
    Join Date
    Dec 2007
    Beans
    518

    Re: lightdm login leads to a wrong environment

    (Slightly off-topic post--can be ignored)
    Note to self on changing the background image: If you do happen to have a working version of unity-greeter, it's controlled by something like unity-greeter.conf. There are lots of nicer pictures you can use in /usr/share/backgrounds. Of course, you can use your own too.

    EDIT:
    But it turns out that that's not the file. It's not lightdm-gtk-greeter-ubuntu.conf either.

    The default ugly background is 'warty-final-ubuntu.png'. Searching the disc for the text 'warty-final-ubuntu' shows 14 files that refer to that file or 'warty-final-ubuntu.jpg', so it's probably one of those. Some seem more likely than others. It may be hard-coded. I'd sure like to replace that image, but....


    EDIT again:
    OK, here's what works.

    If the background file is specified as 'warty-final-ubuntu.jpg', some of the software (which may or may not be running) redirects it to 'warty-final-ubuntu.png' file, as a workaround. So it's a little complicated to get this correct. But there's a simple way to trick it. Why fight it?

    There's only one warty-final-ubuntu.png, and it's in /usr/share/backgrounds. Just replace the file with a file of your choice. Make sure it's a .png file. It's not necessary that the image size match the monitor size.
    Last edited by VanillaMozilla; January 22nd, 2013 at 04:09 PM.

  6. #6
    Join Date
    Dec 2007
    Beans
    518

    Re: lightdm login leads to a wrong environment

    Let us know if the gdm works.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •