Results 1 to 3 of 3

Thread: SSH connection refused?

  1. #1
    Join Date
    Sep 2012
    Beans
    3

    SSH connection refused?

    Every time I try to connect my two laptops via SSH

    Code:
     ssh [username]@192.xxx.x.xx
    I get:

    Code:
     ssh: connect to host 192.xxx.x.xx port 22: connection refused
    What is the problem? Is there something I have to enable on any of the computers?

  2. #2
    Join Date
    Jul 2005
    Beans
    2,047

    Re: SSH connection refused?

    You have to install/enable the OpenSSH server on any computer you are trying to connect to with ssh. Just because you have the ssh client installed doesn't mean the server is installed.

    You could simply install the metapackage for ssh that gets you both server and client:

    Code:
    sudo apt-get install ssh
    on the Ubuntu machine you are trying to connect to.

    I should mention that enabling the ssh server puts that computer at greater security risk, as port 22 will now be open and anyone on a local network that can access that computer could try to access any user account via ssh. So if you enable it, be aware of that!
    Last edited by ahallubuntu; January 11th, 2013 at 10:47 PM.

  3. #3
    Join Date
    Sep 2012
    Beans
    3

    Re: SSH connection refused?

    Thanks, works great now. I did that on both machines and now works just as wanted!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •