Hi, I have a Brother MFC-7860-DW printer/scanner/fax and I am attempting to connect it to my laptop running Ubuntu 12.10. I connected the printer via USB and can print with no issues. Scanning, however, is another story all together.

I have the simple scan app, but that doesn't seem to work/connect to the printer.

I looked online, but so far, I've been unsuccessful. I found the place on the Brother website for the scanner drivers and stuff, but when I attempt to follow Brother's directions, I get error messages.

Like I said, I downloaded the files (both the .DEB and .RPM files) and tried running the commands as the directions on Brother's website lay it out, but it doesn't work...

root@kruxoli-ThinkPad-T60p:/home/kruxoli# dpkg -i --force-all brscan-skey-0.2.4-0.i386.deb
dpkg: error processing brscan-skey-0.2.4-0.i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:

I even tried extracting the file, then replacing the .DEB name with the extracted file name. Still no dice. What am I doing wrong here?

I'm hoping someone can help me. I'm REALLY new to Ubuntu (been running it for a couple of days now since Windows crapped out on me) and I could really use some simple, step by step directions. Please go easy on me. THANKS!!!