Page 1 of 6 123 ... LastLast
Results 1 to 10 of 55

Thread: Can't install wireless Compaq CQ58-253

  1. #1
    Join Date
    Jan 2013
    Beans
    7

    Can't install wireless Compaq CQ58-253

    I have just bought a Compaq CQ58-253 and I've made an Ubuntu 12.04 partition, but I can't figure out how to installa the appropiate wireless driver. I think the wireless devices comes with the blutooth device, but the blutooth device is active.

    My wireless adapter is Qualcomm Atheros QCA9565 802.11b/g/n WiFi Adapter

    By running either "lspci -nn | grep 0280" or "lspci -nn | grep Atheros" I get:
    04:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01)
    I don't get any output by typing:
    $ ifconfig
    $ iwconfig
    $ lsmod
    iwlist scan
    I'm using Ubuntu 12.04 LTS

    Edit:

    I've tried it again after installing
    sudo apt-get install linux-backports-modules-cw-3.6-precise-generic
    but I still don't get anything from
    sudo modprobe ath9k

    SOLVED:
    This is what made it work:
    Quote Originally Posted by chili555 View Post
    ...we install the prerequitites needed to compile:
    Code:
    sudo apt-get install linux-headers-generic build-essential
    Now we download the package, extract it and install it:
    Code:
    wget http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2
    tar xvf compat*
    cd compat-wireless-3.6.6-1-snpc
    sudo su
    ./scripts/driver-select ath9k
    make
    make install
    modprobe ath9k
    exit
    Voila!Your wireless should now be working.
    Last edited by tasclew; January 12th, 2013 at 06:16 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,719
    Distro
    Ubuntu Development Release

    Re: Can't install wireless Compaq CQ58-253

    I don't get any output of "lspci -nn | grep 'Wireless Brand'"
    I think, by 'Wireless Brand' the original author hoped you'd run:
    Code:
    lspci -nn | grep Atheros
    I'd prefer you run and post:
    Code:
    lspci -nn | grep 0280
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jan 2013
    Beans
    7

    Re: Can't install wireless Compaq CQ58-253

    Thank you chili555, I have edited my post with the new information.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,719
    Distro
    Ubuntu Development Release

    Re: Can't install wireless Compaq CQ58-253

    Please try:
    Code:
    sudo apt-get install linux-backports-modules-cw-3.6-precise-generic
    After it's done, do:
    Code:
    sudo modprobe ath9k
    If that doesn't help, we'll plunge into the more complex: http://askubuntu.com/questions/21549...r9565-wireless

    As in many things in life, try the easy way first.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jan 2013
    Beans
    7

    Re: Can't install wireless Compaq CQ58-253

    I've tried the easy way, but it still doesn't work. Should I try the other way? I really don't get how to use the other one, do I have to compile my own driver or something like that?

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,719
    Distro
    Ubuntu Development Release

    Re: Can't install wireless Compaq CQ58-253

    Please reboot and then let's see:
    Code:
    modinfo ath9k | grep -e file -e 0036
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Jan 2013
    Beans
    7

    Re: Can't install wireless Compaq CQ58-253

    This is what I get.

    filename: /lib/modules/3.2.0-35-generic/updates/cw-3.6/ath9k.ko
    By the way, thank you for your help .

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,577
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Can't install wireless Compaq CQ58-253

    Did you also install the compiling tools?

    Code:
    sudo apt-get install linux-headers-generic build-essential dkms
    Reboot and check:
    Code:
    uname -a
    modinfo ath9k | grep -e file -e 0036

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,719
    Distro
    Ubuntu Development Release

    Re: Can't install wireless Compaq CQ58-253

    The absence of an entry for 0036 indicates your device is not covered by the backports package. Let's undertake the process in my link. First, remove the possibly conflicting backports:
    Code:
    sudo apt-get remove --purge linux-backports-modules-cw-3.6-precise-generic
    There is a companion package for your current kernel version and we'll purge it, too:
    Code:
    sudo apt-get remove --purge linux-backports-modules-cw-3.6-`uname -r`
    Those backticks are on the left side of my US keyboard on the same key with ~.

    Now we install the prerequitites needed to compile:
    Code:
    sudo apt-get install linux-headers-generic build-essential
    Now we download the package, extract it and install it:
    Code:
    wget http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2
    tar xvf compat*
    cd compat-wireless-3.6.6-1-snpc
    sudo su
    ./scripts/driver-select ath9k
    make
    make install
    modprobe ath9k
    exit
    Voila!
    $ modinfo drivers/net/wireless/ath/ath9k/ath9k.ko | grep 0036
    alias: pci:v0000168Cd00000036sv*sd*bc*sc*i*
    Your wireless should now be working.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Jan 2013
    Beans
    7

    Re: Can't install wireless Compaq CQ58-253

    praseodym, thanks for your help, but I still get the same message.

    chili555, thank you very much, I will try right now, lets see if it works .

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •