Results 1 to 8 of 8

Thread: xfce4-appfinder recently takes a long time to launch

  1. #1
    Join Date
    Jul 2012
    Beans
    2

    Unhappy xfce4-appfinder recently takes a long time to launch

    xubuntu 12.04 with xfce 4.10

    Installed xubuntu a week or two ago and I have been particularly enjoying xfce4-appfinder. I hit the hotkey and it pops up instantly, or rather it did. Today it's been very sluggish, taking up to 5 seconds to appear after I hit the hotkey.

    It works fine once it has launched, it just takes a long time to get there. I don't believe anything has changed regarding my system and my processor isn't under any stress, etc. I have turned off my computer several times throughout the day but the problem persists.

    Could anyone identify my problem and help me fix it? Or should I give up and try an alternative like synapse or something?

    Thanks,
    Louis

  2. #2
    Join Date
    May 2012
    Location
    UK
    Beans
    617

    Re: xfce4-appfinder recently takes a long time to launch

    i cant help with your underlying issue, but maybe you could try Synapse instead ? have a look, it is a very useful app. it adjusts to your usage. you cant search the settings manager app through it though, the menu file for the settings manager needs to be tweaked, that is all.

  3. #3
    Join Date
    Jul 2012
    Beans
    2

    Re: xfce4-appfinder recently takes a long time to launch

    I'm starting to think that it may be getting progressively slower as my computer is left on. It seemed snappy when I used it to launch my browser an hour ago yet now it seems slower, though no where near as bad as it was earlier in the day. Nothing else is taking a long time to launch.

    I used to use synapse and I'm considering going back to it. Is it still being developed? I heard it was dead.

    edit: Literally the minute I posted this it started taking several seconds to launch. I have absolutely no idea what has changed. I haven't even used any programs other than my browser in that time...

    editedit: I get this error message when I launch it from the terminal. When it does launch but takes ages, that is.

    (xfce4-appfinder:4167): xfce4-appfinder-CRITICAL **: Failed to open window: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    Last edited by MrPopinjay; July 22nd, 2012 at 01:42 AM.

  4. #4
    Join Date
    Sep 2012
    Beans
    3

    Re: xfce4-appfinder recently takes a long time to launch

    hi,

    try to use xfce4-appfinder without becoming D-BUS service

    xfce4-appfinder -c --disable-server

    it worked for me.

  5. #5
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    809
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xfce4-appfinder recently takes a long time to launch

    Quote Originally Posted by tmartiro View Post
    hi,

    try to use xfce4-appfinder without becoming D-BUS service

    xfce4-appfinder -c --disable-server

    it worked for me.
    Thank you tmartiro for the tip. I have been experiencing the same weird delay.

    The Xfce keyboard shortcuts settings map Alt-F2 to xfrun4 which is a symlink for xfce4-appfinder. That's the right place to append -c --disable-server.

    I prefer Synapse most of the time except if I want to run a complicated command (you can't edit the command line in Synapse) or if I want to browse categories. I have heard rumors that it is dead But looking at their launchpad page, it says it is still under active development with future versions planned. No new version since March though, maybe development has simply slowed?

    Cheers!
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  6. #6
    Join Date
    Aug 2005
    Location
    Brussels
    Beans
    135
    Distro
    Ubuntu Development Release

    Re: xfce4-appfinder recently takes a long time to launch

    Quote Originally Posted by tmartiro View Post
    hi,

    try to use xfce4-appfinder without becoming D-BUS service

    xfce4-appfinder -c --disable-server

    it worked for me.
    Thanks for that. This got rid of the delay. Now appfinder is very snappy. Cheers.

    Dafydd

  7. #7
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    890
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xfce4-appfinder recently takes a long time to launch

    I've been having the same problem. Mr. Popinjay, thanks for asking about it! I use appfinder a lot. However, this is what I get

    Code:
    ~$ xfce4-appfinder -c --disable-server
    xfce4-appfinder: Unknown option -c.
    Last edited by Buntu Bunny; January 9th, 2013 at 01:57 AM.
    "Everybody is ignorant, only on different subjects." Will Rogers

  8. #8
    Join Date
    Jun 2008
    Location
    Across The Pond
    Beans
    890
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xfce4-appfinder recently takes a long time to launch

    Quote Originally Posted by Buntu Bunny View Post
    I've been having the same problem. Mr. Popinjay, thanks for asking about it! I use appfinder a lot. However, this is what I get

    Code:
    ~$ xfce4-appfinder -c --disable-server
    xfce4-appfinder: Unknown option -c.
    Irregardless, appfinder is popping up faster than before. Go figure.
    "Everybody is ignorant, only on different subjects." Will Rogers

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •