Results 1 to 2 of 2

Thread: Asus Z77 motherboards

Hybrid View

  1. #1
    Join Date
    Apr 2011
    Ubuntu 12.10 Quantal Quetzal

    Question Asus Z77 motherboards

    Does anyone of you own an asus motherboard based on Z77 chipstet? I plan to buy a new mobo with the latest chipset for ivy bridge. I like asus however I can't find full information how compatible are P8Z77-V models.

    I'm especially concerned about Asmedia USB 3.0 and SATA controllers... does this stuff work at all on Ubuntu? I found some people complaining about but it was like a year ago. How's the situation now? Perhaps you have some better recommendations.

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Asus Z77 motherboards

    If you search forums you can find info.

    I have not seen info on Asus with asmedia, but AsRock.

    AsRock calls BIOS mode AHCI.
    "Launch EFI Shell from Filesystem Device" in the Exit tab of Asrock motherboard
    Asrock Extreme4 Z77 motherboard, which has 4 SATA3 ports: 2 Intel ports (0 & 1) and 2 Asmedia ports (A0 & A1).Had my DVD drive connected to one of the Asmedia ports (A1), and so I tried switching the connection to one of the Intel SATA2 ports and the errors went away.

    UEFI, Windows on SSD, Ubuntu on HD ASRock Z77 Pro4 motherboard
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts