Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: ASUS USB-N13 Wireless Adapter

  1. #1
    Join Date
    Jan 2013

    Angry ASUS USB-N13 Wireless Adapter

    Hi, I'm very new to Ubuntu, with limited command knowledge.

    I've bought a brand new PC without an operating system, and have just installed Ubuntu 12.04.

    All I've done so far is plug in the ASUS usb-n13 - I haven't installed any drivers or anything at all. Without me doing anything, it has picked up the local wifis around. I select mine, it tries to connect, but can't.

    I pretty much have this exact problem, except that I haven't had or tried with any previous versions of Ubuntu, and I haven't tried installing anything yet:

    I imagine that if it can already see the wifi network, that I don't need to install a driver?

    I think I have RTL8192cu, as this name is mentioned in some of the directories in the Linux directory on the installation disk. I read the readme.txt on the installation disk, but it gives no instruction using Network Manager (other than it should just work? And I'm not even sure if this is what I'm using) and I'm not sure if I'm supposed to use the command-line method or not, because it says not to use it with Network Manager (which I'm assuming is what is currently picking up the available wifi networks).

    Here is my lsusb:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 003: ID 0b05:17ab ASUSTek Computer, Inc.
    Bus 002 Device 004: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth

    Can someone please help me get this working!

  2. #2
    Join Date
    Apr 2011
    Ubuntu 14.04 Trusty Tahr

    Re: ASUS USB-N13 Wireless Adapter


    Here's the text of the installation how-to that comes with the adapter.


    sudo make
    [sudo] password for harold-music:
    Sorry, try again.
    [sudo] password for harold-music:
    make[1]: Entering directory `/usr/src/linux-headers-3.5.0-21-generic'
    Building modules, stage 2.
    MODPOST 0 modules
    make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-21-generic'
    rt73.ko failed to build!
    make: *** [module] Error 1

     Installation instructions for the Legacy rt73 module
    Build Instructions
        1. Unpack the driver sources and go to the Module directory:
              $ tar -xvzf rt73-cvs-daily.tar.gz
              $ cd ./rt73-cvs-YYYYMMDDHH/Module
        2. Compile the driver sources:
              $ make
        3. Install the driver (as root):
              # make install
    Load the driver:
        $ modprobe rt73 [ifname=<name>] [debug=<mask>] [firmName=<file>]
        <name> is the name of the device and defaults to "wlan%d". If more
        than one adapter is installed, successive devices will be named
        wlan0, wlan1, etc. If you wish to use a different scheme - say
        eth*, and there are already wired ethernet devices named eth0 and
        eth1, then specifying <name> as "eth%d" gives the adapter the name
        <mask> is a decimal or hex number. See TESTING file. Ignored if
        driver compiled without debug support.
        <file> is the name of a firmware file and defaults to "rt73.bin"
        if omitted. Only the basename - not the full path - may be
    Start it up:
        $ ifup wlan0        # If using Debian - or
        $ ifconfig wlan0 up
        $ iwlist wlan0 scan
    If everything is ok, you should see a list of surrounding Access
    Points. It means you can jump to the configuration section. Otherwise,
    check out the following install notes...
    * Firmware file (rt73.bin)
        The rt73 chipset uses a firmware file which is loaded in device
        memory using the kernel firmware_class facility. 'make install'
        copy the firmware file to the standard firmwares location:
        However some linux distributions divert from the standard and e.g.
        use /lib/firmware/<KERNEL_VERSION>. If this is your case, you will
        have to manually move the firmware file to the right location.
        If you have problems with firmware loading, please ask on your
        distro's support media (forum, etc).
    * Driver alias
        rt73 uses wlan* as its modprobe alias. This means you can have
        several devices and they will be named wlan0, wlan1, etc.
        If for some reason you want this interface number 'static' (e.g.
        if you have several wlan devices and their numbers change on
        reboot) you can change the rt73 alias in /etc/modprobe.d/ralink
        (2.6 kernels) or /etc/modules.conf (2.4 kernels) back to wlan0 (or
        wlan1, etc).
        However the proper way to achieve this purpose is to use a udev
        rule based on the wlan MAC address, for example:
        KERNEL=="wlan*", SYSFS{address}=="00:de:ad:be:ef:00", NAME="wlan0"
    * Module parameters
        You can load the rt73 module with two optional parameters:
           firmName=<FILE_NAME>  Use another firmware file.
           debug=<DEBUG_MASK>    Set debug verbosity (see below).
    Wireless Station Configuration
    The wlan interface should be configured using standard wireless
    extension tools.
        If you're looking for a GUI config tool we provide RutilT on our
        download page
        1. Set the interface mode and bring it up
              # iwconfig wlan0 mode managed
              # ifconfig wlan0 up
        2. Set your target network / Access Point
           If you just want to join a wireless network, set its ESSID:
              # iwconfig wlan0 essid <ESSID>
           If you want to associate with a specific AP, set its MAC
              # iwconfig wlan0 ap <BSSID>
        3. Set encryption if needed
           a) WEP (802.11b)
              Choose the authentication mode (open/restricted):
                 # iwconfig wlan0 key open
                 # iwconfig wlan0 key restricted
              Set the encryption key:
                 # iwconfig wlan0 key <KEY>
           b) WPA (802.11g)
              Set the authentication mode:
                 # iwpriv wlan0 set AuthMode=WPAPSK
              Set the encryption key:
                 # iwpriv wlan0 set WPAPSK=<KEY>
              Set the encryption type:
                 # iwpriv wlan0 set EncrypType=TKIP
           c) WPA2 (802.11i)
              Set the authentication mode:
                 # iwpriv wlan0 set AuthMode=WPA2PSK
              Set the encryption key:
                 # iwpriv wlan0 set WPAPSK=<KEY>
              Set the encryption type:
                 # iwpriv wlan0 set EncrypType=AES
        4. Check that you're associated with an AP
              # iwconfig wlan0
    If everything's ok, you can now configure the wlan0 interface
    statically or dynamically (DHCP). If you need more wireless config
    details and examples (Adhoc mode e.g.), see iwpriv_usage.txt (included
    in driver sources). Otherwise, read the following config notes...
    * Auto-load on boot
        If you want your device to come up on boot the best is to use your
        specific linux distribution's tools (boot scripts, etc).
        If you need support doing so, ask on your distro's support media.
    * wpa_supplicant
        wpa_supplicant is a userland WPA/WPA2/802.1X layer. This driver is
        not compatible with it. As most wpa_supplicant features are
        embedded into our driver, you should not need it though.
        If you need to use a feature that only wpa_supplicant provides:
           - either use our next-generation rt2x00 driver which
             is compatible with wpa_supplicant
           - or patch wpa_supplicant to make it work with rt73 (more info:
    Misc. information
    * hostapd
        hostapd allows your wlan device to act like an Access Point. Legacy
        drivers are _not_ compatible with it, but our next-generation
        rt2x00 drivers are.
    * Network auditing
        Our drivers allow you to peform in-depth wireless network auditing.
        Most of the following settings require that you bring the
        interface down beforehand.
        You can set a custom MAC address as you would do for any other
        ethernet interface:
           # ifconfig wlan0 hw ether <MAC_ADDRESS>
        You can put your wlan interface in promiscuous mode as you would
        do for any other interface:
           # ifconfig wlan0 promisc
        You can put your interface in monitor mode and have it listen to all
        802.11 frames around:
           # iwconfig wlan0 mode monitor
        You can also inject 802.11 frames on the fly. To enable injection,
           # iwpriv wlan0 rfmontx 1
    * Testing / debugging
        If you experience any driver related problem you can ask for
        support on our mailing list or our legacy driver forum.
        Before asking for help, read the TESTING file and follow its
        advice. Do *not* post messages like: "wlan does not work. please
    It may be a similar fix for both. I'll post separately.



  3. #3
    Join Date
    Jan 2013

    Re: ASUS USB-N13 Wireless Adapter

    I had this issue for the longest time too. I was didledaddling with modprobe -r and removed the module that Ubuntu was using for my wifi card. Then I retried to compiled the source and it worked.

    Can you post the output of:


    sudo lshw -c network

    ...while the wifi card is plugged in. Then we can blacklist the original module and compile the one that came with the card and then we'll edit your /etc/modules and place the new module in there so you can boot up with it on all the time
    Last edited by Us3r Unfriendly; January 7th, 2013 at 09:54 AM.

  4. #4
    Join Date
    Jan 2013

    Re: ASUS USB-N13 Wireless Adapter

    Oh and to be exact, is this the card your using:

  5. #5
    Join Date
    Jan 2013

    Re: ASUS USB-N13 Wireless Adapter

    Thanks so much for your reply!!

    Andrew F in Australia: I don't think that's the same one as mine, I have rtl8192_8188cu, not rt73. Also, I did try to follow the steps that came with the installation disk:

    /ASUS USB-N13/Linux/RTL8192CU_linux_v3.0.2164.20110715/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/USB-N13 Linux Driver Quick Start.txt

    but it says "Before installing driver, please check installed compile, make tool and kernel source code. Otherwise, you need to connect to Internet and use yum to install."

    Firstly, I don't know where to check the source code, or what I would be checking. Secondly, if I could connect to the internet, then I wouldn't have a problem

    I tried to follow the instructions below that message anyway, was able to do step 1 (untar the files), but step 2 (make) gives "make: *** No targets specified and no makefile found. Stop."

    Us3r Unfriendly: That is EXACTLY the card I'm using. ASUS USB-N13 802.11b/g/n.

    Here is the output of lsmod:
    Module                  Size  Used by
    nls_utf8               12493  1
    isofs                  39553  1
    bnep                   17830  2
    rfcomm                 38139  0
    bluetooth             158438  10 bnep,rfcomm
    snd_hda_codec_hdmi     31775  1
    snd_hda_codec_realtek   174055  1
    arc4                   12473  2
    eeepc_wmi              12949  0
    asus_wmi               19624  1 eeepc_wmi
    sparse_keymap          13658  1 asus_wmi
    ppdev                  12849  0
    snd_hda_intel          32765  3
    snd_hda_codec         109562  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13276  1 snd_hda_codec
    snd_pcm                80845  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    joydev                 17393  0
    rtl8192cu              97722  0
    rtl8192c_common        69519  1 rtl8192cu
    snd_seq_midi           13132  0
    rtlwifi                95804  1 rtl8192cu
    parport_pc             32114  1
    mac80211              436455  3 rtl8192cu,rtl8192c_common,rtlwifi
    snd_rawmidi            25424  1 snd_seq_midi
    snd_seq_midi_event     14475  1 snd_seq_midi
    cfg80211              178679  2 rtlwifi,mac80211
    snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              28931  2 snd_pcm,snd_seq
    snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
    wmi                    18744  1 asus_wmi
    mac_hid                13077  0
    snd                    62064  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    psmouse                72846  0
    serio_raw              13027  0
    i915                  414603  3
    drm_kms_helper         45466  1 i915
    drm                   197692  4 i915,drm_kms_helper
    soundcore              14635  1 snd
    snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
    i2c_algo_bit           13199  1 i915
    video                  19068  1 i915
    mei                    36570  0
    lp                     17455  0
    parport                40930  3 ppdev,parport_pc,lp
    usbhid                 41906  0
    hid                    77367  1 usbhid
    r8169                  56321  0
    And here is the output of sudo lshw -c network:
           description: Ethernet interface
           product: RTL8111/8168B PCI Express Gigabit Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth0
           version: 09
           serial: c8:60:00:ca:8a:e0
           size: 10Mbit/s
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168f-1_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
           resources: irq:42 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
           description: Wireless interface
           physical id: 2
           bus info: usb@2:1.7
           logical name: wlan0
           serial: c8:60:00:d4:64:d3
           capabilities: ethernet physical wireless
           configuration: broadcast=yes driver=rtl8192cu driverversion=3.2.0-23-generic-pae firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

    All while the card is plugged in. Thanks so much for your advice!
    Last edited by varunendra; March 6th, 2013 at 02:15 PM. Reason: added code tags

  6. #6
    Join Date
    Jan 2013

    Re: ASUS USB-N13 Wireless Adapter

    I have a Asus USB-N13 B1 on 12.10. I followed these instructions and it has been stable for about a day so far.

  7. #7
    Join Date
    Jan 2013

    Re: ASUS USB-N13 Wireless Adapter

    Thanks!!! I am away for a few days, but will try this when I get home and let you know how it goes. Cheers

  8. #8
    Join Date
    Jan 2013

    Angry Re: ASUS USB-N13 Wireless Adapter

    Oh god.

    So I attempted to follow the instructions you linked to (here), starting at Step 4 because I already had the drivers on the installation disk that came with the dongle.

    It looked like it was doing things, but then I got an error message in the terminal. I wasn't able to copy/paste the error message here but I continued on to Step 5 anyway, and then Step 6. Perhaps unsurprisingly (since I got an error on Step 4), things are now worse. Now Ubuntu doesn't even acknowledge that I've plugged in the dongle, let alone see any of the wireless networks

  9. #9
    Join Date
    Jan 2013

    Talking Re: ASUS USB-N13 Wireless Adapter

    OK I finally got this to work!

    1. I downloaded the latest driver for RTL8192CU from the RealTek website:

    2. I untarred the file, then went to the 'driver' directory

    3. Command: make (this creates a file called '8192cu.ko')

    4. I then blacklisted the dongle using Command: sudo gedit /etc/modprobe.d/blacklist.conf where I went to the end of the file and added the line: blacklist rtl8192cu

    5. Back to the 'driver' directory, and typed command: ./clean

    6. Back to the blacklist document, and removed the line that was added to the end of the document (blacklist rtl8192cu)

    7. Back to the 'driver' directory, and typed command: insmod 8192cu.ko

    And now it works!!

  10. #10
    Join Date
    Aug 2005
    South Carolina, USA
    Ubuntu 16.04 Xenial Xerus

    Re: ASUS USB-N13 Wireless Adapter


    I understand you are still having some difficulties. What Ubuntu version are you running?
    lsb_release -d
    What module is loaded now?
    lsmod | grep 8192
    Please confirm your device details:
    I see a flaw or two in your procedure; we'll try to tweak it a bit.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 3 123 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts