Results 1 to 10 of 10

Thread: Network Indicator

  1. #1
    Join Date
    Feb 2006
    Location
    Ottawa, Ontario
    Beans
    300
    Distro
    Ubuntu 14.04 Trusty Tahr

    Network Indicator

    I want to get rid of the indicator for the network information.

    I am on Ubuntu 12.04.

    I found this command

    Code:
    sudo apt-get remove network-manager-gnome
    Found this information,

    Networking: Provided by package network-manager-gnome. DO NOT remove unless you have a desktop with one wired ethernet connection and do not use VPNs.

    Which is true, I only have one wired connection. Though if I do this, am I still able to go into System Settings and get to the Network options?

  2. #2
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    3,085
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Network Indicator

    If you remove Network Manager you will not have anything in any menus to configure networking. You would need to manually configure /etc/network/interfaces. See man interfaces.
    i5 650 3.2 GHz, 8 GB, nvidia GTX 1060, 32" 1080p & assorted older computers

  3. #3
    Join Date
    Feb 2006
    Location
    Ottawa, Ontario
    Beans
    300
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Network Indicator

    So there is no way to get rid of that indicator without causing other problems?

  4. #4
    Join Date
    Apr 2012
    Beans
    6,964

    Re: Network Indicator

    well you can kill the nm-applet process

    Code:
    $ pkill -u $USER nm-applet
    I don't actually know how to prevent it from starting... there must be a way...

    EDIT: no idea why you'd want to though - don't fall into the trap of thinking it prevents the user from accessing the underlying network-manager service (the same functionality is available via nm-tool / nmcli or via dbus)
    Last edited by steeldriver; January 4th, 2013 at 06:01 AM.

  5. #5
    Join Date
    Apr 2012
    Beans
    6,964

    Re: Network Indicator

    so fwiw the answer (for Unity) seems to be to edit the autostart file and add Unity to the list of desktops that the applet is NotShownIn:

    /etc/xdg/autostart/nm-applet.desktop :
    Code:
    [Desktop Entry]
    Name=Network
    Comment=Manage your network connections
    Icon=nm-device-wireless
    Exec=nm-applet
    Terminal=false
    Type=Application
    NoDisplay=true
    NotShowIn=KDE;Unity;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=NetworkManager
    X-GNOME-Bugzilla-Component=general
    X-GNOME-Autostart-enabled=true
    X-Ubuntu-Gettext-Domain=nm-applet

  6. #6
    Join Date
    Feb 2006
    Location
    Ottawa, Ontario
    Beans
    300
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Network Indicator

    Thanks man, will give that a try.

    Which I just realised I don't know how to do..

  7. #7
    Join Date
    Apr 2012
    Beans
    6,964

    Re: Network Indicator

    You would need to open the file in a text editor with root permission

    Code:
    sudo nano /etc/xdg/autostart/nm-applet.desktop
    or

    Code:
    gksudo gedit /etc/xdg/autostart/nm-applet.desktop
    and edit as indicated or just a one-shot with 'sed'

    Code:
    sudo sed -i 's/NotShowIn.*$/&Unity;/' /etc/xdg/autostart/nm-applet.desktop
    Would it be impolite to ask why you want to do this? As noted above, disabling / removing the applet doesn't do anything to secure the connection

  8. #8
    Join Date
    Feb 2006
    Location
    Ottawa, Ontario
    Beans
    300
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Network Indicator

    I don't use it, it gives me no benefit of being on that bar. I like cleaning things up, getting rid of things not needed.

    If I need to change something, which I don't, I can go into the settings.

  9. #9
    Join Date
    Feb 2006
    Location
    Ottawa, Ontario
    Beans
    300
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Network Indicator

    And also, thanks, that worked like a charm!

  10. #10
    Join Date
    Apr 2012
    Beans
    6,964

    Re: Network Indicator

    Glad to help - tbh I had to do some searching to find that, it bugged me that there wasn't an 'obvious' answer

    Also afaik that will disable it for all users - if that's not what you want, there *may* be a per-user equivalent - maybe somewhere in ~/.config ?



    EDIT: for per-user disable:

    0. revert any changes you made in /etc/xdg/autostart/nm-applet.desktop

    1. create a ~/.config/autostart directory if it does not already exist

    Code:
     [ -d ~/.config/autostart ] || mkdir -pv ~/.config/autostart
    2. copy the /etc/xdg version with the appropriate modification

    Code:
    sed 's/NotShowIn.*$/&Unity;/' /etc/xdg/autostart/nm-applet.desktop > ~/.config/autostart/nm-applet.desktop
    3. log out and back in

    Tested on my 12.04 laptop.
    Last edited by steeldriver; January 4th, 2013 at 08:08 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •