Hi, Need some help, much appreciated! I'll get right into it. The problem started when I couldn't connect to a wifi connection from Ubuntu as I am being prompted for a root password, which I don't have and can't get, as I can only log in as a guest, since ubuntu (12.04) does not accept my login details. I'm a complete linux beginner so please bear with me. I recently installed ubuntu thru wubi on my (2nd hand) Asus eeePC (w/o cd-dvd drive), dual booting with win 7 starter. Install was flawless, and when starting up comp I get what I assume is the windows GRUB menu where I have 3 options: "windows 7", "ubuntu" or "windows memory diagnostic" (under "Tools"). If I choose "Ubuntu", a text appears on a black screen saying "mount: can't read proc/mounts: no such file or directory". Then the black screen is suddenly filled with paragraph symbols, before actually starting ubuntu. When I get to the Ubuntu login screen I can only login with a "Guest Session". When I try the normal login and I input my username and password, I am just told that my password is invalid and that I should try again. I have already reinstalled ubuntu as I thought maybe I had mistyped my password or that caps lock was on. But indeed that wasn't the case. I simply can't enter ubuntu with the admin account. I've searched for hours on ubuntu forums and have tried to boot into recovery mode so as to 'reset' my Ubuntu password from the terminal, by pressing (and sometimes holding) Esc or Shift or F6 or F2 or F9 on startup. This is after I have chosen Ubuntu from the windows GRUB menu. I also tried pressing esc and shift while in the windows GRUB menu but to no avail. I can however access the terminal from ubuntu in the guest mode and from the login screen. When I try to log in that way it just tells me my password is invalid as well. I suppose my "root" problem is that I can't get to Ubuntu GRUB menu to apply any of the fixes I have seen on the forums to change password or reinstall drivers or to reinstall the MBR or GRUB settings...(?) So just to sum up: - Can't use wifi from guest access without authentication password, since I - Can't get authentication password through terminal as guest account is not allowed to - Can't enter admin account - Can't get access to Ubuntu GRUB menu with all the kernel and recovery mode options (only windows GRUB menu I reckon) so that I can reset password or update drivers on startup or whatever I would very much like to be able to log into admin account! Not just to connect to Wifi obviously. Starting to get really frustrating! Would very much appreciate any help. Cheers, N