Results 1 to 8 of 8

Thread: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

  1. #1
    Join Date
    Nov 2012
    Beans
    3

    Ralink rt5390 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    Hi,
    My wireless adapter is not working in ubuntu 12.04. The adapter is the ralink rt5390 in a HP envy m4-1015dx laptop.
    The system doesn't loads any driver module for this adapter. I've tried installing the ralink driver in:
    http://www.ralinktech.com/en/04_supp...ort.php?sn=501
    But I couldn't make it work. I could compiled and install the rt5390sta module but it is not associated with my adapter. I've seen other threads solving this for previous versions of ubuntu but not for 12.04.
    Some info about my system:

    $iwconfig
    lo no wireless extensions.
    eth0 no wireless extensions

    $ sudo rfkill list all
    0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no[/CODE]
    Code:
    $lspci -vv
    
    $sudo lspci -vv
    02:00.0 Network controller: Ralink corp. Device 539b
        Subsystem: Hewlett-Packard Company Device 18ed
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at c0600000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
    [CODE]$ sudo uname -r
    3.2.0-32-generic

    Please, if anybody knows how to fixed this I will appreciate it.

    Martin
    Last edited by mabelzunce; November 6th, 2012 at 01:57 PM.

  2. #2
    Join Date
    Nov 2007
    Beans
    12

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    Any luck with this problem? I was considering buying this same laptop, but now I'm a little hesitant.

    Thanks, Kevin.

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    I'm not quite sure why the OP got no reply, it's fairly easy to get this device working. In fact, in Ubuntu 12.10, the driver is built-in: rt2800pci.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Nov 2012
    Beans
    3

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    It's true that in ubuntu 12.10 the wireless works with rt2800pci driver. But in ubuntu 12.04 the adapter is unclaimed even with that driver that is built-in in the kernel. I couldn't make it work in 12.04.
    I've been using 12.10 for a few weeks, but the / and /home partitions were mounted all the time as read only because of a supossed error in the filesystem. This was reported as a bug in 12.10 and it's impossible to work with that bug. So I decided to downgrade to 12.04 and I am still without succes with the wireless adapter.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    Quote Originally Posted by mabelzunce View Post
    It's true that in ubuntu 12.10 the wireless works with rt2800pci driver. But in ubuntu 12.04 the adapter is unclaimed even with that driver that is built-in in the kernel. I couldn't make it work in 12.04.
    I've been using 12.10 for a few weeks, but the / and /home partitions were mounted all the time as read only because of a supossed error in the filesystem. This was reported as a bug in 12.10 and it's impossible to work with that bug. So I decided to downgrade to 12.04 and I am still without succes with the wireless adapter.
    Do you have the same device 1814:539B?
    Code:
    lspci -nn | grep 0280
    We can probably get it working fairly easily.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Nov 2011
    Beans
    2

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    support for 539b chip didn't show up until 2012-05-16. Currently in the 3.5.7 and 3.6.11 kernels (as well as even later kernels).

    use one of the backport meta packages:

    linux-backports-modules-cw-3.5-precise-generic
    linux-backports-modules-cw-3.6-precise-generic

  7. #7
    Join Date
    Dec 2012
    Beans
    1

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    I'm having the same problem with an HP Pavilion p7-1420t. I have an RALink RT5390.

    I tried following the instructions here but have not been successful:
    http://ubuntuforums.org/showthread.php?t=1645716

    I also tried calling "sudo apt-get install linux-backports-modules-cw-3.6-precise-generic", still no luck.

    iwconfig:
    Code:
    lo        no wireless extensions.
    eth0      no wireless extensions.
    lspci -vv:
    Code:
    ...
    03:00.0 Network controller: Ralink corp. Device 539b
        Subsystem: Hewlett-Packard Company Device 18ed
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 255
        Region 0: Memory at f7d00000 (32-bit, non-prefetchable) [disabled] [size=64K]
        Capabilities: <access denied>
        Kernel modules: rt2800pci
    ...
    I'm a bit of a linux newbie. Any suggestions on how to fix this? Thank you.

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Raling ra3950 in ubuntu 12.04 not working (HP Envy m4-1015dx)

    Quote Originally Posted by dg520 View Post
    I'm having the same problem with an HP Pavilion p7-1420t. I have an RALink RT5390.

    I tried following the instructions here but have not been successful:
    http://ubuntuforums.org/showthread.php?t=1645716

    I also tried calling "sudo apt-get install linux-backports-modules-cw-3.6-precise-generic", still no luck.

    I'm a bit of a linux newbie. Any suggestions on how to fix this? Thank you.
    Please let us see:
    Code:
    sudo modprobe rt2800pci
    dmesg | grep -i rt2
    rfkill list all
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •