Page 1 of 2 12 LastLast
Results 1 to 10 of 32

Thread: Lubuntu does not use all of my RAM

Hybrid View

  1. #1
    Join Date
    Aug 2010
    Beans
    17

    Lubuntu does not use all of my RAM

    I am running Lubuntu 12.10 64bit on my hp nx7400 laptop.
    I recently upgraded my RAM to 4GB (2x2GB memory modules), however sysinfo only displays 3.3GB of available RAM.

    In the bios I can clearly see 4GB of ram installed and I can also run a diagnosis check on the memory in the bios. So it seems to be operating system related.

    So, I am wondering what happened to the rest of it.

    In this post: http://ubuntuforums.org/showthread.p...0#post12429300
    it is suggested that it might have something to do with shared video memory, however it is not posted how to verify that.

    Does someone know how to:

    • check the amount shared video memory?
    • change the amount of shared video memory?
    • find out what else might be the cause?

  2. #2
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Lubuntu does not use all of my RAM

    HI

    This question keeps coming up.

    http://unix.stackexchange.com/questi...y-have-4-0-gib

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  3. #3
    Join Date
    Aug 2010
    Beans
    17

    Re: Lubuntu does not use all of my RAM

    Quote Originally Posted by matt_symes View Post
    HI

    This question keeps coming up.

    http://unix.stackexchange.com/questi...y-have-4-0-gib

    Kind regards
    Thank your for the response. Your link, however, seems to be related to 32 bit operating system and architecture. My operating system and architecture is 64 bit:

    for example


    • unem -a gives: Linux martin-HPnx7400 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    • sudo lshw |grep cpu, gives: *-cpu
      bus info: cpu@0
      capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow cpufreq

    Accoring to wikipedia x86-64 means 64 bit and thus the cause should be something else!

  4. #4
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Lubuntu does not use all of my RAM

    Is there a setting in your BIOS for allocating shared video memory? On my motherboard I can adjust how much RAM the onboard video adapter uses.
    Cheesemill

  5. #5
    Join Date
    Aug 2010
    Beans
    17

    Re: Lubuntu does not use all of my RAM

    Quote Originally Posted by Cheesemill View Post
    Is there a setting in your BIOS for allocating shared video memory? On my motherboard I can adjust how much RAM the onboard video adapter uses.
    No, unfortunately not.

  6. #6
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,918
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lubuntu does not use all of my RAM

    did you try reinstallin the kernel after the RAM upgrade? RAM sometimes doesn't get configured automatically

    Code:
    sudo apt-get install linux-image && sudo apt-get update

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  7. #7
    Join Date
    Sep 2013
    Beans
    3

    Re: Lubuntu does not use all of my RAM

    is there any way to use Lubuntu 13 64-bit memory of 8 GB?

  8. #8
    Join Date
    Sep 2013
    Beans
    3

    Re: Lubuntu does not use all of my RAM

    Well, come to detail, something I should have done from the beginning.


    Motherboard asrock N68-S3-fx
    2 memories 1X 4GB DDR3 1600.


    Sata 160 gb HD.


    In bios I provides the total memory 8 GB shared 256
    with nvidia onboard.




    Systems tested Lubuntu 13:04 64 and 32 bits.




    The installation of both works only with 1 stick of memory connected.


    And in Sees Maximum 3 GB, both 64-bit and 32.


    When I add another comb memory, the boot screen is dark. Blank Screen.


    In 32-bit system the only kernel that worked with 2 sticks Memory was the generic 3.2.40 for ubuntu.


    But I only view 3 GB of memory.


    I installed kernel-pae, gave me black screen again, Blank Screen, it stop there.


    In the 64-bit, even compiling the kernel 3.2.40, still blank screen, the thing is when I put the other comb 4 GB, 8 GB total, is in blank Screen and not out there.


    The I modified grub also for possible problems blank screen, changing the grub splash quiet to modonoset.


    Only works with one memory of 4 GB, which displays only 3 Gb


    The OS was installed via USB stick.
    Yet this does not influence.


    Anyone can say what I can do for my Lubuntu use 8 GB?

  9. #9
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Lubuntu does not use all of my RAM

    You'd be much better off starting a new thread for your questions.

  10. #10
    TenPlus1's Avatar
    TenPlus1 is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    May 2005
    Location
    Scotland, UK
    Beans
    837
    Distro
    Lubuntu

    Re: Lubuntu does not use all of my RAM

    Gfx memory usage is setup in the bios which you would have to change each time, their is no automatic way of doing this...

    So long as your system works ok even with 3.3gb of memory available hold on for some future updates either for Ubuntu itself through the kernel or your laptop bios and I'm sure one of these will fix the memory available for you...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •