My wife just got a System76 Gazelle Professional and the wireless acts strangely - and I think it is just incompatible with our "routers"

If the laptop is plugged in (power) it will connect and work well. As soon as it is unpluged (power) and running on batteries the ping speed (to google.com) goes from about 58-60ms to like 250-300ms and starts dropping packets.

The same test at our fire hall causes the ping time to increase from about 59ms to 150ms, but no packets get dropped.

so. . . What is a compatible router? The laptop has a Centrino Wireless-N 1030 in it.

More details you can skip if you want;
The home network works fine with my iMac, and an Acer Aspire One running MINT. Booting this laptop with MINT (live disk) yields the same issue.

The 2 wireless devices I have, and tried are a Siemens Gigaset SE567 (crap) and an Apple Airport Express (Apple ) The fire hall has a D-Link DIR-### (517 I think)

The issue of dropped packets and slow ping speed is ONLY when the power cord is disconnected. (so when the wireless card is in some sort of power save mode)

Again my question is What do you recommend for a router? (I already tried a small handful of fixes, but I think it is a hardware incompatibility as it works fine at the fire hall)