Results 1 to 4 of 4

Thread: 12.10 arrow keys resize window's size in VNC

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Beans
    13

    Question 12.10 arrow keys resize window's size in VNC

    Hi,
    i've got an headless ubuntu 12.10 server, i connect onto it with my Chicken Of Vnc client
    from a Mac Book Pro.

    When i use the terminal inside my VNC session (full screen mode), the up arrow key doesn't browse the commands
    history as usual, but it resizes the terminal window..

    How do i avoid such behavior?
    Experienced the same issue with VNC Client on Windows 7. So maybe it's something wrong in my vncserver settings...


    Thank you in advance

  2. #2
    Join Date
    Nov 2010
    Beans
    14

    Re: 12.10 arrow keys resize window's size in VNC

    I got same problem using ArchLinux, Gnome 3, and VNCserver. This is very annoying, who on earth would want this crap. I cant see anything thinking that this is a good default feature.

    It is not present in x11vnc, so it is vncserver. I have used VNC Viewer for Mac/Windows, Apples Remote Desktop Viewer, Chicken, bVNC and Jump for android. This "bug" is present in all of them.

  3. #3
    Join Date
    Nov 2010
    Beans
    14

    Re: 12.10 arrow keys resize window's size in VNC

    Apparently, it is an issue with the great(sarcasm) Gnome 3/Unity.

    Quoting: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682916

    PHP Code:
    Gnome appears to be interpreting <up> and <down> as Super-<up> and
    Super-<down>.  I tested both servers, and from both the vinagre and
    xvnc4viewer clients.

    As 
    a workaroundyou can go to the keyboard control panel and change the
    keybindings to remove Super
    +Up and Super+Down from the Windows section
    After changing mine ( they wont let you disable this feature ), it worked!

  4. #4
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: 12.10 arrow keys resize window's size in VNC

    Quote Originally Posted by SirKingChase View Post
    Apparently, it is an issue with the great(sarcasm) Gnome 3/Unity.

    Quoting: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682916

    PHP Code:
    Gnome appears to be interpreting <up> and <down> as Super-<up> and
    Super-<down>.  I tested both servers, and from both the vinagre and
    xvnc4viewer clients.

    As 
    a workaroundyou can go to the keyboard control panel and change the
    keybindings to remove Super
    +Up and Super+Down from the Windows section
    After changing mine ( they wont let you disable this feature ), it worked!
    THANK YOU this is the only thing i could find on the internet about this matter. this is applicable to debian wheezy too now it is sorted thanks again.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •