Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Acer C7: Anyone else have one?

  1. #21
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acer C7: Anyone else have one?

    Quote Originally Posted by PhoHammer View Post
    It's fanless right? I would get it just for that "feature". There's nothing better than not hearing that constant whirrrrr of a fan or HDD.
    No, the C7 has a fan. The Samsung Chromebook and the Pixel are fanless.

  2. #22
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    2,056
    Distro
    Ubuntu Mate

    Re: Acer C7: Anyone else have one?

    I have been having a great deal of fun with ChrUbuntu, using razor-qt as a DE, and using a USB mouse, BTW, which eliminated the "how do you middle-click with the trackpad?" question.

    Oh, yes, I'm upgrading RAM. Soon. SSD? Maybe; I like the HD capacity I have.

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  3. #23
    Join Date
    Aug 2013
    Beans
    0

    Re: Acer C7: Anyone else have one?

    Quote Originally Posted by rickyrockrat View Post
    So I've found some interesting things out. First, NFS is not built into the kernel, and many of the drivers are not built, even as modules, so I built my own kernel. Here's how I did it. I've attached the files that I used, except I changed a few things in linux-build.txt I built all of the code in my $HOME/src directory.
    BACK UP before you start:
    I backed up /boot and /lib/modules/3.4.0 like so:
    cd /
    sudo cp -a boot boot.orig
    cd lib/modules
    sudo cp -a 3.4.0 3.4.0.orig
    sudo dd if=/dev/sda6 of=/kernel.orig

    You need the keys from the chromeos:
    mkdir m
    sudo mount -o ro /dev/sda3 m
    sudo cp -a m/usr/share/vboot to /usr/share
    sudo umount m

    The git clone of the kernel is pulling the Linux kernel from GIT, and it's about 1.2G, so it will take some time to download.
    If you want to keep the kernel pristine, at the level you did the git command (lndir -> apt-get install xutils-dev), do:
    mkdir -p build/kernel
    cd build/kernel
    lndir ../../kernel
    Then run all the commads from there: make oldconfig/make-kpkg kernel_image kernel_headers
    In linux-build.txt, Ignore the patch of the base.config, and instead copy the chromiuos-3.4.0.config to .config in the kernel build directory, then do:

    make oldconfig

    Ignore the part where it does the vbutil_kernel --verify, and use the kernel-cmd.txt file in place of the config-$tstamp.txt

    The above config and kernel command line fix drivers not loading, and of course give you a ton more input drivers (for mice and such). This was why one of my USB mice would not work - no driver built. I also added NTFS file systems and other basic optional drivers.

    If for some reason the vbuil tools don't work as copied, do this:
    sudo apt-get install libyaml-dev liblz-dev liblzma-dev lzma-dev uuid-dev libssl-dev libtspi-dev
    git clone http://git.chromium.org/chromiumos/p..._reference.git
    cd vboot_reference
    make
    sudo make install
    Cheers!
    The trackpad works a lot better under Chrome OS... Will your kernel improve the trackpad under ubuntu?

    I don't really understand what to do after "sudo umount m"

    Sorry, I am new to ubuntu.

  4. #24
    Join Date
    Sep 2007
    Location
    Boise,ID
    Beans
    119
    Distro
    Kubuntu

    Re: Acer C7: Anyone else have one?

    Gecko2,
    Make sure you read all provided info. If you don't, you will find the open source community will quickly loose patience with you. RTFM is often said, which means Read The Fine Manual (Fine was another word, but I don't use it).

    There are three attached files. Download & read them. In linux-build.txt, there is a section that shows how to git clone the kernel. linux-build.txt can be run by doing:
    bash linux-build.txt
    That command tells the shell to run the file as a shell script, executing all the instructions in there as thought you had typed them yourself.

    But make sure you understand what it is doing! Some people will tell you to run commands that are malicious, and even if they are not malicious, there could be a mistake that wipes your system.

    If you don't trust linux-build.txt to be correct, just cut & paste sections of it into some file, then do the bash some-file. Alternatively, you can make your script executable with:
    chmod 755 some-file
    then run it
    ./some-file.
    If you really don't trust it, run the commands by typing (or cutting & pasting each line) them one at a time. REALLY examine commands like mv, rm, fdisk, mk* (mkfs, mke2fs, etc) especially when run as root.
    One more thing, don't use root to run commands unless you HAVE to. I always configure and make softwre as a normal user.

    A command like chown -R user:user path/to/some/directory will change that dirctory and all files under it (-R) so they are owned and in the same group as the user named 'user'. Only do this to directories that have software source. Doing that to directories on the root file system can do Bad Things.
    Last edited by rickyrockrat; August 25th, 2013 at 02:36 PM.

  5. #25
    Join Date
    Aug 2013
    Beans
    2

    Re: Acer C7: Anyone else have one?

    Hey rickyrockcat, and friends --

    I've bought myself a C7 with the intention of using it as a thin client to remote into work, etc. I need PPTP to connect to the VPN at the office, but all the necessary modules are not part of the kernel. So I've been trying to piece things together in an attempt to configure/recompile the kernel to add this support. Your post is the closest thing I've found to what I've been hoping to accomplish, so thank you for that glimmer of hope.

    I *think* I have the config file altered to include all of the PPTP related modules. Things seemed to be going fairly smoothly tonight, until I get to make-kpkg kernel_image kernel_headers

    I run as "sudo" and get the output included below, with the errors in bold at the end.... Everything looks like it's going fine (to me, anyway) and then gcc complains about a parameter and it quits. Any suggestions on what's happening or for how to troubleshoot this further?

    Thanks!!


    Code:
    exec make kpkg_version=12.036+nmu3 -f /usr/share/kernel-package/ruleset/minimal.mk debian
    ====== making target debian/stamp/conf/minimal_debian [new prereqs: ]======
    This is kernel package version 12.036+nmu3.
    test -d debian             || mkdir debian
    test ! -e stamp-building || rm -f stamp-building
    install -p -m 755 /usr/share/kernel-package/rules debian/rules
    for file in ChangeLog  Control  Control.bin86 config templates.in rules; do                                      \
                cp -f  /usr/share/kernel-package/$file ./debian/;                               \
            done
    for dir  in Config docs examples ruleset scripts pkg po;  do                                      \
              cp -af /usr/share/kernel-package/$dir  ./debian/;                                 \
            done
    test -f debian/control || sed         -e 's/=V/3.4.0/g'  \
                    -e 's/=D/3.4.0-10.00.Custom/g'         -e 's/=A/i386/g'  \
            -e 's/=SA//g'  \
            -e 's/=I//g'                    \
            -e 's/=CV/3.4/g'                \
            -e 's/=M/Unknown Kernel Package Maintainer <unknown@unconfigured.in.etc.kernel-pkg.conf>/g'                \
            -e 's/=ST/linux/g'      -e 's/=B/i386/g'    \
                      /usr/share/kernel-package/Control > debian/control
    test -f debian/changelog ||  sed -e 's/=V/3.4.0/g'       \
                -e 's/=D/3.4.0-10.00.Custom/g'        -e 's/=A/i386/g'       \
                -e 's/=ST/linux/g'     -e 's/=B/i386/g'         \
                -e 's/=M/Unknown Kernel Package Maintainer <unknown@unconfigured.in.etc.kernel-pkg.conf>/g'                            \
                 /usr/share/kernel-package/changelog > debian/changelog
    chmod 0644 debian/control debian/changelog
    test -d ./debian/stamp || mkdir debian/stamp 
    make -f debian/rules debian/stamp/conf/kernel-conf
    make[1]: Entering directory `/home/user/build/kernel'
    ====== making target debian/stamp/conf/kernel-conf [new prereqs: ]======
    make    ARCH=i386 \
                        oldconfig;
    make[2]: Entering directory `/home/user/build/kernel'
    scripts/kconfig/conf --oldconfig Kconfig
    #
    # configuration written to .config
    #
    make[2]: Leaving directory `/home/user/build/kernel'
    make    ARCH=i386 prepare
    make[2]: Entering directory `/home/user/build/kernel'
    scripts/kconfig/conf --silentoldconfig Kconfig
    make[2]: Leaving directory `/home/user/build/kernel'
    make[2]: Entering directory `/home/user/build/kernel'
    make[3]: Nothing to be done for `all'.
    make[3]: Nothing to be done for `relocs'.
      CHK     include/linux/version.h
      CHK     include/generated/utsrelease.h
      CC      kernel/bounds.s
    gcc: error: unrecognized command line option '-fstack-protector-strong'
    make[3]: *** [kernel/bounds.s] Error 1
    make[2]: *** [prepare0] Error 2
    make[2]: Leaving directory `/home/user/build/kernel'
    make[1]: *** [debian/stamp/conf/kernel-conf] Error 2
    make[1]: Leaving directory `/home/user/build/kernel'
    make: *** [debian/stamp/conf/minimal_debian] Error 2
    Failed to create a ./debian directory:  at /usr/bin/make-kpkg line 984.

  6. #26
    Join Date
    Sep 2007
    Location
    Boise,ID
    Beans
    119
    Distro
    Kubuntu

    Re: Acer C7: Anyone else have one?

    Make sure gcc is up to date. Do apt-cache search gcc |grep gcc to get the correct name for apt. In fact, perhaps just do:
    sudo apt-get update
    sudo apt-get upgrade
    should bring your system up to date.
    It acts like gcc is building for the wrong target or the config/gcc is mis-matched.
    Google (in this case) is sorta your friend (actually, they are the ones that messed it up in the first place, not to mention that nasty NSA thing):
    googling : unrecognized command line option "-fstack-protector-strong"
    returns:
    So, depending on your gcc and when you get the kernel source you may need to edit /usr/src/kernel/arch/x86 Makfile
    Line 78 change "stackp-y := -fstack-protector-strong" to stackp-y := -fstack-protector-all
    apparently google added the strong option to their build of gcc and you may get an error saying this is not defined

    from here:
    https://groups.google.com/forum/#!ms...k/WUIALBzD4R0J
    references:
    http://ml.reddit.com/r/chrubuntu/com...el_modules_eg/
    Cheers

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •