Hi everyone! I'm openning this new thread cause I think is a very specific situation am In.

Yesterday I just installed Ubuntu 12.04, Windows 7 and Windows XP in the same hard drive. As I expected, there was no menu at booting to choose the OS to start with, since this is not new for me, I just applied the common solution for this, so I used the following commands:

sudo fdisk -l
sudo mount /dev/sdaX /mnt (where X is the Ubuntu Installation Partition)
sudo grub-install –-root-directory=/mnt/ /dev/sda

This used to solve the problem! But yesterday it didn't, I also tried:

sudo mount /dev/sdaX /mnt
sudo mount --bind /dev /mnt/dev
sudo chroot /mnt
grub-install --recheck /dev/sda

And it was the same! When I turn on the PC, Ubuntu starts directly D=

Does anyone have an idea? Thanks!