Results 1 to 5 of 5

Thread: Apache fails to start

  1. #1
    Join Date
    Apr 2006
    Beans
    2,154

    Apache fails to start

    Hi all

    OS - Ubuntu 12.04 desktop 64bit running as VM
    Virtualizer Oracle VirtualBox
    airtime 2.2.1-1

    phpmyadmin NOT installed.

    $ sudo service apache2 start
    Code:
     * Starting web server apache2
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    Action 'start' failed.
    The Apache error log may have more information.
       ...fail!
    $ tail /var/log/apache2/error.log
    Code:
    [Wed Jan 16 15:26:06 2013] [notice] Apache/2.2.22 (Ubuntu) configured -- resuming normal operations
    [Wed Jan 16 15:26:07 2013] [notice] caught SIGTERM, shutting down
    [Wed Jan 16 15:26:08 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.4 with Suhosin-Patch configured -- resuming normal operations
    [Wed Jan 16 15:34:43 2013] [notice] caught SIGTERM, shutting down
    Please advise where to check and how to fix the problem? TIA

    B.R.
    satimis

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Apache fails to start

    Code:
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    Based on that, your site configuration file has an error on line 5. So that's what you should check. Of course you can post the contents of that file here if you want other people to take a look..

  3. #3
    Join Date
    Apr 2006
    Beans
    2,154

    Re: Apache fails to start

    Quote Originally Posted by mcduck View Post
    Code:
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    Based on that, your site configuration file has an error on line 5. So that's what you should check. Of course you can post the contents of that file here if you want other people to take a look..
    $ cat /etc/apache2/sites-enabled/airtime-vhost
    Code:
    <VirtualHost *:80>
          ServerName icecast.mydomain.com
          #ServerAlias www.example.com
    
          ServerAdmin root@localhost An email address is required for the virtual host configuration.     
    
          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php
    
          SetEnv APPLICATION_ENV "production"
    
          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>
    line 5 - original
    Code:
    ServerAdmin root@localhost An email address is required for the virtual host configuration.
    Tried;
    1)
    satimis@icecast.mydomain.com
    2)
    satimis@mydomain.com

    Also tried;
    ServerName www.mydomain.com

    satimis@mydomain.com (mail address)

    All failed.

    Apache2 was automatically installed when running;
    Code:
    $ sudo apt-get install airtime
    I suspect there is another config file its content must be matched.

    Must "hostname" be matched?

    $ hostname
    Code:
    ub1204dk02
    $ hostname -f
    Code:
    ub1204dk02
    Thanks

    satimis

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Apache fails to start

    Just change this:
    Code:
    ServerAdmin root@localhost An email address is required for the virtual host configuration.
    ...into this:
    Code:
    ServerAdmin root@localhost
    The rest of the text on the line doesn't belong there and result in the error about the ServerAdmin option only accepting one parameter (having all the other words on the same line would make each word a new parameter for the option. And of course none of the words would be a valid parameter even if the option accepted more than one...

  5. #5
    Join Date
    Apr 2006
    Beans
    2,154

    Re: Apache fails to start

    Quote Originally Posted by mcduck View Post
    Just change this:
    Code:
    ServerAdmin root@localhost An email address is required for the virtual host configuration.
    ...into this:
    Code:
    ServerAdmin root@localhost
    The rest of the text on the line doesn't belong there and result in the error about the ServerAdmin option only accepting one parameter (having all the other words on the same line would make each word a new parameter for the option. And of course none of the words would be a valid parameter even if the option accepted more than one...
    Hi,

    Thanks for your advice. I got it done

    satimis

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •