Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: zfs.ko missing after update to 12.10

  1. #21
    Join Date
    Apr 2009

    Re: zfs.ko missing after update to 12.10

    EDIT: The approach advised at the post below resolves this version of the problem:

    I have encountered this error on 12.04.2 LTS after removing a bunch of old kernel modules.

    Attempting the final stage in stephenvaningen's post #19 gives
    # sudo apt-get install zfs-dkms ubuntu-zfs
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Suggested packages:
    The following NEW packages will be installed
      ubuntu-zfs zfs-dkms
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/2,092 kB of archives.
    After this operation, 10.5 MB of additional disk space will be used.
    Selecting previously unselected package zfs-dkms.
    (Reading database ... 426944 files and directories currently installed.)
    Unpacking zfs-dkms (from .../zfs-dkms_0.6.1-1~precise_amd64.deb) ...
    Selecting previously unselected package ubuntu-zfs.
    Unpacking ubuntu-zfs (from .../ubuntu-zfs_7~precise_amd64.deb) ...
    Setting up zfs-dkms (0.6.1-1~precise) ...
    Loading new zfs-0.6.1 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-43-generic
    Building initial module for 3.2.0-43-generic
    configure: error: 
    	*** Please make sure the kmod spl devel <kernel> package for your
    	*** distribution is installed then try again.  If that fails you
    	*** can specify the location of the spl objects with the
    	*** '--with-spl-obj=PATH' option.
    Error! Bad return status for module build on kernel: 3.2.0-43-generic (x86_64)
    Consult /var/lib/dkms/zfs/0.6.1/build/make.log for more information.
    Setting up ubuntu-zfs (7~precise) ...
    /var/lib/dkms/zfs/0.6.1/build/make.log shows:
    DKMS make.log for zfs-0.6.1 for kernel 3.2.0-43-generic (x86_64)
    Sun May 19 13:42:25 BST 2013
    make: *** No targets specified and no makefile found. Stop.
    Kernel packages are installed on my system as follows:
    # dpkg --get-selections | grep linux-image
    linux-image-3.2.0-43-generic			install
    linux-image-server				install
    I continue to get this error:
    # zpool status
    Failed to load ZFS module stack.
    Load the module manually by running 'insmod <location>/zfs.ko' as root.
    Failed to load ZFS module stack.
    Load the module manually by running 'insmod <location>/zfs.ko' as root.
    Very grateful indeed for any advice on resolving this.
    Last edited by 13eastie; May 19th, 2013 at 02:21 PM.

  2. #22
    Join Date
    Jun 2010

    Re: zfs.ko missing after update to 12.10

    I wish things worked seamlessly, but the following worked for me after my last update (I'm on 12.04, but I doubt the Ubuntu version matters here) and seems a little simpler than the earlier workarounds proposed:

    apt-get install --reinstall zfs-dkms
    zfs mount -a
    Hope this works for others and maybe someone can eventually recommend a true fix.


Page 3 of 3 FirstFirst 123

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts