Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Random Reboot

  1. #1
    Join Date
    Jan 2009
    Location
    Gilbert, AZ, USA
    Beans
    38
    Distro
    Ubuntu 10.04 Lucid Lynx

    Random Reboot

    I have Mythbuntu 12.04.1 running and am experiencing random reboots.

    I have ruled out all hardware issues (Memory, Power, etc)
    I have monitored cpu and system tempratures.
    I have tried running 64 and 32 bit OS variants.
    I have checked the system, kernel, dmesg, and Xorg logs, with no indication of trouble.

    I'm running a Biostar NM70I-847 MB with onboard Intel Graphics, no additional drivers used.

    I'm at wit's end. Where do I go from here?
    Last edited by GJLenon; December 15th, 2012 at 07:40 AM.
    "Only out of the exigencies of discord comes discourse." - Bahktin

  2. #2
    Join Date
    Oct 2007
    Beans
    338

    Re: Random Reboot

    How old is the machine? is the power supply large enough to handle the load? Have you recently Installed anything new?? Changed Anything? More often than not its hardware related although it can be software related just not as often.

  3. #3
    Join Date
    Jan 2009
    Location
    Gilbert, AZ, USA
    Beans
    38
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Random Reboot

    Quote Originally Posted by chadk5utc View Post
    How old is the machine? is the power supply large enough to handle the load? Have you recently Installed anything new?? Changed Anything? More often than not its hardware related although it can be software related just not as often.

    Thanks for the reply. It's a new build. All components replaced. System is stable under Win7 build.
    "Only out of the exigencies of discord comes discourse." - Bahktin

  4. #4
    Join Date
    Jan 2009
    Location
    Gilbert, AZ, USA
    Beans
    38
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Random Reboot

    Apparently it only reboots when the Myth Backend is running...
    "Only out of the exigencies of discord comes discourse." - Bahktin

  5. #5
    Join Date
    Jan 2013
    Beans
    2

    Angry Re: Random Reboot

    Quote Originally Posted by GJLenon View Post
    I have Mythbuntu 12.04.1 running and am experiencing random reboots.
    I experienced same random reboots on NM70I-847 too.
    There is no problem and stable on WindowsXP, Windows8, CentOS6.3 and FreeBSD9.0.
    (FreeBSD is only CUI)
    Rebooting occurs on Ubuntu12.10, LinutMint13, LinuxMint14.

    I feel this rebooting occurs on newer linux kernel.
    So, I built newest kernel 3.7.1 and tried on Mint14. But rebooting occured.

    Finally, I am using NM70I-847 with Windows8. It's very stable.

  6. #6
    Join Date
    Mar 2012
    Beans
    6

    Re: Random Reboot

    Hi guys (and gals ),

    I also bought this mainboard a while ago and also found that it runs perfectly stable with Win8 and older Linux Distros, like CentOS and Debian Stable. So, anything with an older kernel. Running Ubuntu 12.04, 12.10, Debian Testing/Wheezy or even OpenSuse 12.3 resulted in the mentioned sporadic reboots.

    That seemed kind of suspicious, which is why I continued with some more testing.

    What I came up with is the following theory:

    It seems that the random crashes/reboots are based on Intel i915 RC6 (graphics core deep sleep) being enabled.

    When I tested the theory on my Debian Wheezy install (yeah, I know, no Ubuntu ), the reboots stopped.

    Try to add "i915.i915_enable_rc6=0" to /etc/default/grub "GRUB_CMDLINE_LINUX_DEFAULT". Should look something like this then:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=0"
    Then run:
    Code:
     
    sudo update-grub
    And reboot.

    If it remains stable that way, let me know!
    Also if anyone knows how to check if RC6 is enabled in Windows, let me know about that, too. Would be great to know if Win8 runs stable with or without RC6 being active.
    Because the question that needs answering the most is: Is this a BIOS problem, or is it the Linux Kernel?

    Edit:
    It seems like RC6 is disabled in Win8 by default. For one, the power consumption always was a little higher in Win8, in comparison to Linux with i915 RC6 enabled per command line. And, when disabling RC6 completely in BIOS, the power consumption figures didn't increase while idling in Win8. So, this could still be a BIOS issue, which only hits Linux, because Windows has the problematic option disabled by default.

    Edit 2:
    Should also work to just completely disable the two BIOS options concerning RC6. The effect should be the same, as changing the /etc/default/grub file.

    Edit 3:
    Last edit after a long time. The procedure, described in "Edit 2" does NOT work! The BIOS option either doesn't work at all, or just gets ignored by the Linux kernel. So, the way with editing the grub file is the only one tht seems to work, so far.
    Last edited by MadOCer; January 10th, 2014 at 11:15 PM.

  7. #7
    Join Date
    Jan 2013
    Beans
    2

    Re: Random Reboot

    Quote Originally Posted by MadOCer View Post
    Try to add "i915.i915_enable_rc6=0" to /etc/default/grub "GRUB_CMDLINE_LINUX_DEFAULT".
    I tried this on USB stick.(Since I'm already in Win8 stable operation for TV recording.)
    Operating system is LinuxMint 13 MATE Edition 32bit.
    Kernel version is 3.2.34 build without SATA drivers.

    Before the change of GRUB setting, reboot occured twice within 3 hours.
    After the change of GRUB setting, no reboot occured within 20 hours.

    I think this change is to be effective!
    Thank you!

  8. #8
    Join Date
    Mar 2012
    Beans
    6

    Re: Random Reboot

    Just a little follow up on this problem. I sent two mails to Biostar support about this problem + an additional one about USB booting. Obviously Biostar doesn't give a "you know what"! I never heard back from them and there is no fix! So, you know what to make of this. It's a real shame. They should be embarassed by their own lack of support, but it seems they just don't care.

  9. #9
    Join Date
    Mar 2012
    Beans
    6

    Re: Random Reboot

    Well, well, well...
    After months that the board just laid around, and BIOSTAR not giving a damn about the obvious problems with it, I had enough.
    I still would like to use the board, but then it should work like it is supposed to!
    So, I went ahead, installed Win7 + the great application "Thottlestop", which can display exactly which C-States the CPU uses to save power. With that data as proof I fired off a new suppot case to Biostar.
    The CPU doesn't ever reach the C6 state, which is supposed to be its deepest sleep state. And that, even though it is explicitly enabled in BIOS.
    The wrong/erroneous implementation of the C6 (RC6) sleep state is also the problem that causes the Linux kernel to crash. I tested it! Problem is that the Linux Kernel even ignores the BIOS setting (if that even works). I set the RC6 feature in BIOS to disabled, but the Linux kernel still tried to use it and crashed. Added the bootargs, like described above, to disable i915 RC6 and it works.

    Now I am VERY interested to see, if a) they even understand the problem, b) pass it on correctly to a BIOS engineer and c) fix it accordingly, now that it's a "Windows problem".
    Last edited by MadOCer; November 20th, 2013 at 01:58 PM.

  10. #10
    Join Date
    Nov 2013
    Beans
    3

    Re: Random Reboot

    I've also this MB, and also randomly reboots, disabling RC6 on i915 module stopped the reboots.

    Ps: on BIOS it's already disabled but continues rebooting if not disable in i915 module!

    a lot of thanks for you MadOCer!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •