Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: 12.04 and RTL8101E/RTL8201E

  1. #1
    Join Date
    Dec 2012
    Beans
    25

    12.04 and RTL8101E/RTL8201E

    Ubuntu 12.04 and RTL8101E/RTL8201E PCI Express Fast Ethernet Controller

    I am completely new to linux. I have installed kxStudio on ubuntu 12.04 (upgraded from 10.x install). I was successfully booting with the kxStudio 3.2.0-33-lowlatency kernel.

    All seemed well except for poor network connectivity. So I followed the instructions in post #3 (KomodoDave) here: http://ubuntuforums.org/showthread.php?t=1964200

    Here is the gist of that post:

    Download drivers.

    Then
    Code:
    sudo gedit  /etc/modprobe.d/blacklist.conf
    Add line
    Code:
    blacklist r8169
    Then
    Code:
    sudo update-initramfs -u && cd ~/Downloads && tar xvf r8101-1.022.00.tar.bz2 && cd r8101-1.022.00 && sudo sh autorun.sh
    Unfortunately after taking these steps my computer will not boot using the low latency kernel (it stops with a black screen immediately after grub). It will boot using the 2.6.32-45 kernel.

    Having booted with the 2.6.x kernel I commented out the 'blacklist r8169' line in blacklist.conf but the computer will still not boot using the low latency kernel.

    I need the low latency kernel because 2.6.x does not see my usb soundcard. I also believe I will need the low latency kernel for audio work.

    How do I best remedy this situation? I presume the first step is to recover the use of the low latency kernel. However, because I do not at all understand KomodoDave's final command I have no idea what to do.

    Additional Info
    I can only boot with the 2.6.x kernel. With this it appears (from lspci -v) the computer is using the r8169 drivers even if I have the 'blacklist r8169' line in blacklist.conf. I understand so little!

    Also, I have removed and (re)installed the low latency kernel but no difference.

    Also, I never was able to boot 12.04 using the default 3.2.0-34 kernel (it stops after grub with a blank screen the colour of the desktop). I had to use the 2.6.x kernel. However, before trying to fix the network card the pc did boot with the low latency kernel.

    Low Latency Kernel Is Back
    I took a punt and it worked - After commenting out the 'blacklist r8169' line in blacklist.conf I ran:
    Code:
    update-initramfs -u -k -all
    I am now again able to use the low latency kernel.

    So I appear to be back where I started - able to use the low latency kernel but with a poor network connection.

    Any suggestions to solve my poor network connectivity much appreciated.
    Last edited by philwx; December 12th, 2012 at 05:44 PM. Reason: Low Latency Kernel Is Back

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,818
    Distro
    Ubuntu Development Release

    Re: 12.04 and RTL8101E/RTL8201E

    I am troubled by all the commands strung together with && because you can't isolate and correct any problems along the way. Second, I notice that r8101-1.023.00 is available: http://www.realtek.com.tw/Downloads/...&GetDown=false

    I suggest you download it and do each step individually:
    Code:
    cd ~/Downloads
    tar xvf r8101-1.023.00.tar.bz2
    cd r8101-1.023.00
    sudo sh autorun.sh
    If there is an error or even something that smells funny, stop and ask. We'll unload and blacklist r8169 at the end if it all goes well.

    I also assume you have previously installed linux-headers-generic and build-essential.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Dec 2012
    Beans
    25

    Re: 12.04 and RTL8101E/RTL8201E

    Hello Chili555, thank you very much for helping. Here is the output:

    Check old driver and unload it.
    rmmod r8101
    Build the module and install
    DEPMOD 3.2.0-33-lowlatency
    load module r8101
    Updating initramfs. Please wait.
    update-initramfs: Generating /boot/initrd.img-3.2.0-33-lowlatency
    Completed.
    phil@phil-desktop:~/Downloads/r8101-1.023.00$

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,818
    Distro
    Ubuntu Development Release

    Re: 12.04 and RTL8101E/RTL8201E

    Looks pretty good so far. Let's verify some things:
    Code:
    lspci -nn | grep 0200
    lsmod | grep r8
    cat /etc/modprobe.d/blacklist.conf | tail -n5
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Dec 2012
    Beans
    25

    Re: 12.04 and RTL8101E/RTL8201E

    Sorry for the delay in responding but I have to email the output to a windows pc to successfully comment (I can read this thread in ubuntu but cannot post).

    Here's the output:

    phil@phil-desktop:~/Downloads/r8101-1.023.00$ lspci -nn | grep
    0200 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
    phil@phil-desktop:~/Downloads/r8101-1.023.00$ lsmod | grep r8
    r8101 90426 0
    phil@phil-desktop:~/Downloads/r8101-1.023.00$ cat /etc/modprobe.d/blacklist.conf | tail -n5
    # continues to build and is installable for the few cases where its
    # really needed.
    blacklist amd76x_edac
    # blacklist r8169
    # blacklist r8101
    phil@phil-desktop:~/Downloads/r8101-1.023.00$

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,818
    Distro
    Ubuntu Development Release

    Re: 12.04 and RTL8101E/RTL8201E

    We know that's the correct driver for your device from modinfo:
    Code:
    # modinfo src/r8101.ko
    filename:       src/r8101.ko
    version:        1.023.00-NAPI
    license:        GPL
    description:    RealTek RTL-8101 Fast Ethernet driver
    author:         Realtek and the Linux r8101 crew <netdev@vger.kernel.org>
    srcversion:     4AFC1A1629E24088CD227A4
    alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
    depends:        
    vermagic:       3.5.0-19-generic SMP mod_unload modversions 686 
    parm:           eee_enable:int
    parm:           speed:force phy operation. Deprecated by ethtool (8). (array of int)
    parm:           duplex:force phy operation. Deprecated by ethtool (8). (array of int)
    parm:           autoneg:force phy operation. Deprecated by ethtool (8). (array of int)
    parm:           rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
    parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
    parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)
    We see that it's loaded and r8169 is not. I suggest you change the blacklist file to un-comment r8169:
    Code:
    # really needed.
    blacklist amd76x_edac
    blacklist r8169
    # blacklist r8101
    Now do you have an interface, ideally eth0?
    Code:
    ifconfig
    Will it connect? Is it fast, fast, fast? Are we solved??
    (I can read this thread in ubuntu but cannot post).
    Why, because the ethernet is too slow or what?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Dec 2012
    Beans
    25

    Re: 12.04 and RTL8101E/RTL8201E

    2.6.32-45 kernel

    Before I ran your these commands I had to restart. The computer would not boot using the 3.2.0-33-lowlatency kernel. I am now using the 2.6.32-45 kernel.

    I uncommented the line in blacklist file.

    Here's the ifconfig output:

    phil@phil-desktop:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:30:67:3b:ca:24
    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::230:67ff:fe3b:ca24/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:758 errors:0 dropped:0 overruns:0 frame:0
    TX packets:824 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:685645 (685.6 KB) TX bytes:104056 (104.0 KB)
    Interrupt:26

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

    phil@phil-desktop:~$

    However, the network connection is still poor. I can browse some web sites consistently, others are inconsistent, others are never loaded. I thinklighter web sites load better but I cannot download firefox extensions (which is how I would normally measure page size).

    I can load this thread but not post. Larger packages seem to have trouble downloading using package manager. I previously tried chrome browser and it was the same.

    So I ran your previous commands again:

    phil@phil-desktop:~$ lspci -nn | grep 0200
    02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
    RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
    phil@phil-desktop:~$ lsmod | grep r8
    r8169 34140 0
    mii 4381 1 r8169
    phil@phil-desktop:~$ cat /etc/modprobe.d/blacklist.conf | tail -n5
    # continues to build and is installable for the few cases where its
    # really needed.
    blacklist amd76x_edac
    blacklist r8169
    # blacklist r8101
    phil@phil-desktop:~$

    It seems the r8169 drivers is still being used. Is this because I am using the 2.6.x kernel?

    So I restarted again but this appears to have changed nothing. Still not able to use low latemcy kernel. The commands above return the same output.

    Thanks again for your help,
    Phil

  8. #8
    Join Date
    Dec 2012
    Beans
    25

    Re: 12.04 and RTL8101E/RTL8201E

    I'm sorry Chili555 but I completey missed this earlier:

    Quote Originally Posted by chili555 View Post
    I also assume you have previously installed linux-headers-generic and build-essential.
    The answer is I do not know. So I suspect not.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,818
    Distro
    Ubuntu Development Release

    Re: 12.04 and RTL8101E/RTL8201E

    It seems the r8169 drivers is still being used. Is this because I am using the 2.6.x kernel?
    Yes. You compiled r8101 for the 3.2.0-33-lowlatency kernel and not 2.6.x. Are there any clues as to why it won't boot here?
    Code:
    less /var/log/syslog
    less allows you to use the arrow keys or PgUp and PgDn to look for the problem at the time you tried and failed to boot. Get out of less with q.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,818
    Distro
    Ubuntu Development Release

    Re: 12.04 and RTL8101E/RTL8201E

    Quote Originally Posted by philwx View Post
    I'm sorry Chili555 but I completey missed this earlier:



    The answer is I do not know. So I suspect not.
    I suspect so, or the r8101 compile would have stopped in an error or two. It didn't, did it? Didn't it compile without complaint?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •