Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Amavisd & SpamAssassin doesn't work - Ubuntu Server 12.04LTS

  1. #11
    Join Date
    Dec 2012
    Beans
    8

    Re: Amavisd & SpamAssassin doesn't work - Ubuntu Server 12.04LTS

    R_Lopez: Thanks. The only thing I dislike about Untangle is its essentially a packet sniffing solution. It sits in between your mail server and the network as a bridge. Outside of that, it's performed very very well.

    If I could get MailScanner actually WORKING I'd be happy to use that. At least then I can set up a mailbox for SpamAssassin to grab ham from to learn to recognize good email.

    It's one of the biggest problems I have with a Linux based solution for anything. I'm all for open source, and I love Linux but if I can't get a product to install or function it doesn't matter how good that product is.

  2. #12
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    11,410
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Amavisd & SpamAssassin doesn't work - Ubuntu Server 12.04LTS

    Have you, in fact, tried installing MailScanner on a CentOS 6.x machine? As I said before, the package that Julian provides on the MailScanner site installs everything you need with little or no work on your part. You'd need to edit MailScanner.conf, of course, but most of the defaults are reasonable. He also offers a package that includes both ClamAV and SpamAssassin, but I just use the standard CentOS RPMs for those. For ClamAV you should add the Repoforge (formerly RPMForge) repository.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #13
    Join Date
    Dec 2012
    Beans
    8

    Re: Amavisd & SpamAssassin doesn't work - Ubuntu Server 12.04LTS

    SeijiSensei: Yes. I did. It didn't work. I got Postfix installed, and MailScanner. The virus scanning worked perfectly. Spam scanning didn't. It simply would not write the email headers into any of the mail for any spam checks, default or otherwise. CENT OS 5.9 with MailScanner. I even went to MailScanners IRC channel & everyone there was completely baffled. Posted all my configs, etc & nobody could figure out why the headers weren't getting written. So I gave up on it.

    If I *could* get it working on *something* I'd be willing to try it but I spent about two weeks tinkering with it but I chose to cut my losses & go with a pre-packaged/paid solution.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •