Machine: HP Envy dv6-7247cl Notebook
Wireless: RT5390
OS: Ubuntu 12.04 LTS (uname -mr: 3.2.0-34-generic x86_64)

lspci | grep "Netw"
04:00.0 Network controller: Ralink corp. Device 539b

lo no wireless extensions.
eth0 no wireless extensions.

rt5390sta 1451753 0 <--- I ran this after completing the steps below

dmesg | grep rt5390sta
[ 9.720306] rt5390sta: module license 'unspecified' taints kernel.

*-network UNCLAIMED
description: Network controller
product: Ralink corp.
vendor: Ralink corp.
physical id: 0
bus info: pci@0000:04:00.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:c2500000-c250ffff
================================================== ========================

This is a brand new laptop on which I installed Ubuntu 12.04. The wireless card is not recognized. I tried to follow the instructions presented in the following posts:

but I wasn't successful. When I install Ubuntu 12.10, the network card is picked up as RT2800 and it works fine as noted in this thread Unfortunately, I do need 12.04!

The driver that I downloaded is: 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_v2. bz2.bz2

1. Unzipped bz2 file mentioned above.
2. Changed the following in .\os\linux\
HAS_WPA_SUPPLICANT=y #was already y
3. Ran the following:
sudo make
sudo make install
Both ran without errors.
4. Then
sudo rm -rf /etc/Wireless/RT2860STA
sudo mkdir /etc/Wireless/RT5390STA
sudo cp RT2860STA.dat /etc/Wireless/RT5390STA/RT5390STA.dat
5. When I look under /lib/modules/3.2.0-34-generic/kernel/drivers/net/wireless
I do see that rt5390sta.ko was copied there with the right timestamp.

6. In /etc/modules I have added rt5390sta

7. In /etc/modprobe.d/blacklist.conf I have
blacklist rt2800pci

I have rebooted the laptop but I do not see the Wireless adapter in the terminal or UI. I would appreciate any help with this. Thanks.