Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: How to make SystemsSettings remeber that RecordActivity should be off?

  1. #11
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Judging by the Launchpad bug I mentioned above, I'm the only one having this „problem“...
    I'll investigate further to see if I could be to blame...
    Ignota nulla curatio morbi.

  2. #12
    Join Date
    Jun 2007
    Beans
    16,731

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    From the other day (actually 2) it did return after a cold restart.
    Since then hasn't, the setting has held after doing the same with one add.
    disable in SS, disable online, clear history
    edit .desktop -
    sudo nano /usr/share/applications/activity-log-manager-ccpanel.desktop
    change to StartupNotify=false

  3. #13
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Quote Originally Posted by mc4man View Post
    From the other day (actually 2) it did return after a cold restart.
    Since then hasn't, the setting has held after doing the same with one add.
    disable in SS, disable online, clear history
    edit .desktop -
    sudo nano /usr/share/applications/activity-log-manager-ccpanel.desktop
    change to StartupNotify=false
    That did not work but You've gave me clue how to prove and illustrate what is happening here at my place:
    Code:
    :~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:1686): gnome-control-center-unity-WARNING **: testing load
    
    ** (gnome-control-center:1686): CRITICAL **: file blacklist-dbus.c: line 772: uncaught error: Error calling StartServiceByName for org.gnome.zeitgeist.Engine: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/zeitgeist-daemon exited with status 21 (g-dbus-error-quark, 25)
    
    (gnome-control-center:1686): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    
    ** (gnome-control-center:1686): CRITICAL **: alm_files_widget_construct: assertion `blacklist_interface != NULL' failed
    
    (gnome-control-center:1686): GLib-GObject-CRITICAL **: g_object_ref_sink: assertion `G_IS_OBJECT (object)' failed
    
    (gnome-control-center:1686): Gtk-CRITICAL **: gtk_notebook_append_page: assertion `GTK_IS_WIDGET (child)' failed
    
    ** (gnome-control-center:1686): CRITICAL **: alm_applications_widget_construct: assertion `blacklist_inter != NULL' failed
    
    (gnome-control-center:1686): GLib-GObject-CRITICAL **: g_object_ref_sink: assertion `G_IS_OBJECT (object)' failed
    
    (gnome-control-center:1686): Gtk-CRITICAL **: gtk_notebook_append_page: assertion `GTK_IS_WIDGET (child)' failed
    
    ** (gnome-control-center:1686): CRITICAL **: alm_blacklist_get_incognito: assertion `self != NULL' failed
    
    (gnome-control-center:1686): GLib-GObject-WARNING **: invalid (NULL) pointer instance
    
    (gnome-control-center:1686): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
    
    (gnome-control-center:1686): LibZeitgeist-CRITICAL **: Failed to create proxy for Zeitgeist daemon: Error calling StartServiceByName for org.gnome.zeitgeist.Engine: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/zeitgeist-daemon exited with status 21
    
    ** (gnome-control-center:1686): CRITICAL **: alm_blacklist_get_incognito: assertion `self != NULL' failed
    
    ** (gnome-control-center:1686): CRITICAL **: alm_blacklist_set_incognito: assertion `self != NULL' failed
    Now I have to findthat setting alm_blacklist_get_incognito and ...
    Last edited by zika; December 12th, 2012 at 04:54 PM.
    Ignota nulla curatio morbi.

  4. #14
    Join Date
    Jun 2007
    Beans
    16,731

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Here that command comes up relatively clean
    Code:
    ~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:3255): gnome-control-center-unity-WARNING **: testing load
    
    (gnome-control-center:3255): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    Then the panel shows still disabled, ect.

  5. #15
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Quote Originally Posted by mc4man View Post
    Here that command comes up relatively clean
    Code:
    ~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:3255): gnome-control-center-unity-WARNING **: testing load
    
    (gnome-control-center:3255): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    Then the panel shows still disabled, ect.
    I get the same dialog...
    Code:
    vindsl@Zuul:~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:494): gnome-control-center-unity-WARNING **: testing load
    
    (gnome-control-center:494): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    But, the panel always shows "Record Activity" is enabled, every time I check...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  6. #16
    Join Date
    Jun 2007
    Beans
    16,731

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Quote Originally Posted by VinDSL View Post
    I get the same dialog...
    Code:
    vindsl@Zuul:~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:494): gnome-control-center-unity-WARNING **: testing load
    
    (gnome-control-center:494): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    But, the panel always shows "Record Activity" is enabled, every time I check...
    While I'm going to re-enable soon staying off here with nothing showing in the files lens other than default folders.
    Don't think there is is reason it's staying disabled other than that's what it's supposed to do..

    (did make me aware of yet another nautilus focus issue - default folders opened from files lens open behind FF & gnome-terminal, unity only

  7. #17
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Quote Originally Posted by VinDSL View Post
    I get the same dialog...
    Code:
    vindsl@Zuul:~$ gnome-control-center activity-log-manager
    
    (gnome-control-center:494): gnome-control-center-unity-WARNING **: testing load
    
    (gnome-control-center:494): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
    But, the panel always shows "Record Activity" is enabled, every time I check...
    Now You're talking... I'm not alone. Go and check the bug report given above ...
    Ignota nulla curatio morbi.

  8. #18
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Quote Originally Posted by mc4man View Post
    While I'm going to re-enable soon staying off here with nothing showing in the files lens other than default folders.
    Don't think there is is reason it's staying disabled other than that's what it's supposed to do..

    (did make me aware of yet another nautilus focus issue - default folders opened from files lens open behind FF & gnome-terminal, unity only
    Same here...
    Ignota nulla curatio morbi.

  9. #19
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Still no way of making „RecordActivity>Off“ stick...
    Still light in refrigirator on all the time...
    Ignota nulla curatio morbi.

  10. #20
    Join Date
    Jul 2007
    Location
    Hillsboro, OR
    Beans
    317
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How to make SystemsSettings remeber that RecordActivity should be off?

    Looks like I found the issue. Due to some weird-ass reason, the application was crashing the daemon to which it connected to. Or maybe the daemon crashes long back before the app started
    I reported the bug upstream too

    https://bugs.freedesktop.org/show_bug.cgi?id=65491
    Zeitgeist and Ubuntu Privacy Manager Developer


Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •