Results 1 to 4 of 4

Thread: 12.04.1 no audio through HDMI

Threaded View

  1. #1
    Join Date
    May 2012

    12.04.1 no audio through HDMI

    Hello all, first, sorry if this is not posted under the right forum.

    CPU: AMD A10-5800K 3.8G 4M FM2 R
    Mobo: MSI FM2-A75MA-E35
    OS: Ubuntu 12.04.1 LTS

    Fresh copy, updated vid drivers to "ATI/AMD proprietary FGLRX graphics driver". This enabled better resolution, higher-end graphics, etc.

    HDMI out works, but only for video, not sound. There is no option to enable it in the sound settings. Other posts with similar issues report an "HDMI" device, I do not have it listed.

    aplay -l output:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Installed Win7 on the machine, after installing MSI drivers, HDMI audio out works (so no physical issues).

    It would rock if anybody had some idea of where my HDMI audio out has gone

    Thanks for the help, let me know what info you need from me!

    PS: In ubuntu, normal audio (headphone jack) works fine, only HDMI sound doesn't.


    Tried to update audio driver, found in the ubuntu wiki that one can update their 'alsa' drivers.

    Did this:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Tried this line:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    My uname -r output = 3.2.0-34-generic

    But got an "unable to locate package".
    Tried with altering above string, with or without $ it failed, number alone, etc, nothing works.

    Found some forum posts about 'alsa' not being available anymore and that you need to build your own, but was not sure...

    UPDATE 2:
    lspci -v | grep -A7 -i "audio"
    00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device 9902
            Subsystem: Micro-Star International Co., Ltd. Device 7721
            Flags: fast devsel, IRQ 18
            Memory at feb44000 (32-bit, non-prefetchable) [size=16K]
            Capabilities: <access denied>
            Kernel modules: snd-hda-intel
    00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 15h (Models 10h-1fh) Processor Root Port (prog-if 00 [Normal decode])
    00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
            Subsystem: Micro-Star International Co., Ltd. Device d721
            Flags: bus master, slow devsel, latency 32, IRQ 16
            Memory at feb40000 (64-bit, non-prefetchable) [size=16K]
            Capabilities: <access denied>
            Kernel driver in use: snd_hda_intel
            Kernel modules: snd-hda-intel
    Last edited by failmaster; December 5th, 2012 at 12:38 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts