Results 1 to 3 of 3

Thread: GRUB installation errors

  1. #1
    Join Date
    Jun 2006
    Ubuntu 9.10 Karmic Koala

    GRUB installation errors

    I installed Linux Mint and got an error installing GRUB. I ran boot-repair, which also failed and gave me this link:
    Can anyone help me with this?

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: GRUB installation errors

    New drives now are configured to start first partition at sector 2048 for compatibility with new 4K drives or SSDs. It also gives more space from MBR to allow the embedding of grub2's core.img.Your first partition starts at sector 63 which was the standard with XP, Vista changed and then gparted/Linux changed a couple of years ago to start sda1 at 2048.

    Something about your core.img, probably the btrfs makes it very large.

    Error from Boot-Repair or grub:
    Reinstall the GRUB of sda6 into the MBR of sda
    /usr/sbin/grub-bios-setup: warning: your core.img is unusually large. It won't fit in the embedding area.
    /usr/sbin/grub-bios-setup: error: filesystem `btrfs' doesn't support blocklists.
    grub-install /dev/sda: exit code of grub-install /dev/sda:1
    Is there some reason for btrfs?

    Ubuntu 12.04 LTS - Benchmarking All The Linux File-Systems
    Large HDD/SSD Linux 2.6.38 File-System Comparison: EXT3, EXT4, Btrfs, XFS, JFS, ReiserFS, NILFS2
    Last edited by oldfred; December 4th, 2012 at 12:26 AM.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Jan 2008
    Ubuntu Development Release

    Arrow Re: GRUB installation errors

    Quote Originally Posted by Baruch by email
    Quote Originally Posted by YannBuntu by email
    You tried to use BTRFS, but your 1st partition (Windows) starts too close from the start of the disk to let GRUB be installed.
    I recommend you use EXT4 instead of BTRFS.
    It worked! Thank you!
    Where can I find an explanation of why this happens? I am curious.
    The explanation is that GRUB2 needs a bigger space (before the first partition of the disk) when using BTRFS then EXT4.
    And your disk doesn't have such big space.
    You could use GRUB2 with BTRFS if you could increase the free space before your 1st partition.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts