I have a new Asus Q500A laptop with 6gb ram, 750gb hard drive and Windows 8 Home preinstalled. CPU is Intel Core i5-3210M

It has the AMI Aptio UEFI bios which allows booting from the regular Ubuntu 12.10 cd as well as the 12.10 secure remix (which I'm using, more on that below).

I was able to shrink the Windows partition to 258gb and install Ubuntu 12.10 to a 20gb root/boot partition plus a 400gb /usr partition.

I can boot the live cd and mount the installed Ubuntu partitions as well as the first partition, which is a FAT32 UEFI boot partition.

Once I ran boot repair from the Ubuntu 12.10 secure remix, I was able to boot to grub and (after some hiccups) make it my default boot. This is the link for the boot repair output: http://paste.ubuntu.com/1377659/

The grub menu shows the Windows UEFI boot loader and it works as expected.

Trying to load Ubuntu 12.10 from grub results in no disk or screen activity. Using the advanced options added to grub and the recovery option shows the messages "Loading initrd" then no screen mode change and no disk activity. Dropping to the grub command prompt and manually putting in kernel options with noefi and various other options suggested in this thread: http://ubuntuforums.org/showthread.php?p=12373674 I get the same results.

I've reinstalled a couple of times and get the same results. The live CD works fine. I am able to run a VMware lubuntu image under Windows 8.

My next step would be to build a kernel and initrd with more early debug info and put them on there (which I can do, just haven't had time yet).

I've also looked at options in the BIOS which seem that they might have an effect on this but nothing seemed obvious, and in any case they had no effect on this problem.

I've also tried using the earlyprintk kernel option (which I'm used to using in embedded work) but I get nothing out of that.

Turning on set debug=all in the grub2 command environment gives me a couple of pages of malloc() messages then causes erratic behavior.

I haven't been able to find any other options for debugging early in the grub load process but it looks to me more like a problem in the early stages of kernel init and may require some remapping of memory, possibly related to the UEFI environment.