Hey y'all~

Ever since the last round of updates (which included an x.org server update) my system has been acting screwy. My specs are:

Asus P8P67 Motherboard
Intel Core i7 2600 @ 3.4GHz
XFX AMD Radeon HD 6870 1GB
OCZ Agility 3 120GB SSD (with the OS on it)
Western Digital Caviar Black 1TB HDD (split into 2 partitions, one Windows 7 Ultimate partition and another 500GB partition for data on the Linux machine)
External USB 3.0 3TB HDD (I think that it's Western Digital but I don't remember off the top of my head).

Anyways. My problems are as follows:

1. I have 2 monitors on this setup, a 20" Dell Ultrasharp running at 1680x1050 and a 24" Dell Professional running at 1920x1080. Every time I boot into the system (and it doesn't matter if I log out and log back on or do a reboot/cold start) the resolution of the 24" monitor is 1680x1050. I have to go into AMD Catalyst Control Center and change the resolution of the monitor manually. It didn't do this before the last round of updates last week.

2. A couple of unwanted programs open when I log back into the machine. These programs are: KDirStat and an extra instance of xclock (for a total of 2 instances of xclock). I've tried clearing out my sessions cache and saving a new session via the GUI but that doesn't change anything.

3. Alt-F2 doesn't work anymore. I'll press those keys to get the application launcher and nothing happens. The only work around I've found is to go to the Application Finder and search for the command that I want to enter (but not all of them are listed).

4. I can't change the Window Manager Theme or the Style (under Appearance). I've tried rebooting after selecting them and it doesn't change, I've also tried clearing the session cache and saving a new session and the changes aren't present.

5. I can't change the system icons. They're stuck at some really ugly ones and it's very annoying. Again, I've tried clearing the session cache and saving a new session, but the changes aren't showing up. One interesting thing to note is that when I first log in to the machine the external drives (which haven't been mounted yet) show the correct icon theme, but when I move the mouse over them they change to the ugly icons that I don't want.

6. The eyes-plugin that I've installed doesn't remember the last configuration that I had it set to. It defaults to "Tango" instead of "Default" which is what I prefer.

I've been able to determine (in my opinion, at least) that it's an update which has broken my install. I've tried re-installing Xubuntu to no avail, it'll work at first...but as soon as I install updates to it the installation will break. I've also tried restoring to an image that I made about a month ago. When I restore the image the system is working like it should but as soon as updates get installed the system is broken again. There are hundreds of updates so it's not really possible to try them one by one until I notice the one that breaks it.

Any help would be greatly appreciated on any of the issues that I've noticed. I've been a Linux user for a number of years so I'm fairly proficient at the command line and what not, but these problems are new to me so it'd be useful to get specific commands to try as I'm not the most advanced user out there.