Results 1 to 7 of 7

Thread: Ubuntu--Firefox--Wordpress controls issue

  1. #1
    Join Date
    Nov 2012

    Question Ubuntu--Firefox--Wordpress controls issue

    My current setup is Ubuntu 12.04 / Firefox 16.0.2 / Wordpress 3.4.2

    Am trying to work with a WP theme called Modernize.

    There are default option of image Sliders - Flex/Nivo available in the theme. In the setup page, the button "Select Media" when clicked is non-responsive and hence I am unable to upload images into the slider. I am finding the same result with Chrome as browser on Ubuntu.

    I have used the same theme with Wordpress 3.4.2 on a windows xp machine with Chrome browser and it seems to be working fine.

    I am unable to understand the exact problem. Is it something to do with Javascript ? I tested my browser with websites like and the javascript is running just fine.

    I wasn't sure which category should I post this in. I would appreciate any directions/feedbacks for diagnosing the issue.

    Thanks Rakhoush

  2. #2
    Join Date
    Feb 2007
    Athens, Ohio
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ubuntu--Firefox--Wordpress controls issue

    I don't have an answer for you rakhoush, just a question.

    Are you running Wordpress locally, that is, does it reside on you computer rather than at your ISP?

    I'm trying to install Wordpress to run on my computer so that I can learn Wordpress without having to be online. Haven't succeeded yet.

    Looking for your reply.

  3. #3
    Join Date
    Apr 2011

    Re: Ubuntu--Firefox--Wordpress controls issue

    I am having the same issue with WordPress 3.5-RC1 which is beta so I am assuming that its something still in the works. but yes I cant add any images in my posts nether because the add media button no longer works and have had no luck with google so fare..

  4. #4
    Join Date
    Jan 2010
    CT USA
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu--Firefox--Wordpress controls issue

    I did this and it worked fine under 12.04:

    Install LAMP server

    sudo apt-get install lamp-server^
    Note: the ^ above is not a typo
    Reboot - may not be neccessary but to be on the safe side

    Install Wordpress

    sudo apt-get install wordpress
    sudo ln -s /usr/share/wordpress /var/www/wordpress
    sudo bash /usr/share/doc/wordpress/examples/setup-mysql -n wordpress
    sudo chown -R www-data /usr/share/wordpress
    Important note: In the setup-mysql script the location of the Wordpress site is defined - here I defined

    Then access

    The first time you access the Wordpress URL, you come to the Wordpress quick setup screen:
    Then Wordpress is installed and brings you to the login screen.

    This installed Wordpress 3.3.1

    Note to log into the admin panel, use URL:
    To login as a user, use URL:

    Worked like a champ for me. HTH

  5. #5
    Join Date
    Nov 2012

    Re: Ubuntu--Firefox--Wordpress controls issue

    @weedwacker, I am running the server on my own machine which cjhabs has posted the method for the same.

    @superdaveozzborn what i am trying to do now, is to try and edit the source and get the image onto it coz the images are typically taken from wp-content/uploads/<year>/<month>/<files>
    I will update if I find some luck here.


  6. #6
    Join Date
    Nov 2009
    Kubuntu 14.04 Trusty Tahr

    Re: Ubuntu--Firefox--Wordpress controls issue

    you could use firebug to see what the button calls and why the function is not reposnding.
    Easy to understand Ubuntu manual with lots of pics:
    Do i need antivirus/firewall in linux?
    User friendly disk backup: Redobackup

  7. #7
    Join Date
    Nov 2012

    Re: Ubuntu--Firefox--Wordpress controls issue


    Please check the image/gallery settings to see if you need to upload the images using "set featured image" or any other link beforehand.

    And once your uploads are in place then you could possibly go to the pages and add images to the posts or slider.

    The confusion arises when there is a button to select media which doesn;t work. This is the reason it wasn't working because the idea of select media is to select from already uploaded images, which one needs to do from the main gallery settings.

    After a long detour, I finally managed with the existing options.

    @mastablasta thanks for your reply. I did use firebug but couldn't trace this issue as the images were not there to be selected, while the logic laid somewhere else to make the selection pool beforehand.


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts