Quote Originally Posted by sirvinniei View Post
most pcs should already have booting cd-rom above hdd so turning off uefi should be fine.
If it doesn't boot after turning it on try searching your bios for something like: boot priority or boot order and put your cd-rom drive to the top of the list
Already searched...could not find any option for booting from CD-ROM in the Bios. There was no boot order option either. The only option was just a stupid Windows secure boot.