For a long time I connected to my home W-Lan at an indicated strength of 56%. Just activated the Broadcom driver which comes with Ubuntu 12.10 and since I connect at 100%.

Main Menu - System Tools - System Settings - System - Software Sources - Additional Drivers - Activate "Using Broadcom ...."

Michael