Page 6 of 6 FirstFirst ... 456
Results 51 to 53 of 53

Thread: No EFI boot on Dell Inspiron One 2330

  1. #51
    Join Date
    Jul 2006

    Re: No EFI boot on Dell Inspiron One 2330


    I bought this Dell Inspiron 2330 too, and I was highly interested in this thread. I wish here to report my own successfull experience on this machine, hoping it can be helpfull.

    Like you, I wanted to keep the pre-installed Windows 8 and to have a dual win/ubuntu boot, and I managed to do so in UEFI mode with secure boot activated.
    I'll just give you an overview of my experience and mention what could explain, at first glance, why my installation went fine while yours didn't.

    The first thing I have done with this computer after unpacking is upgrading it. It included, of course, windows and dell software, but also BIOS upgrade to version A09 (release date : 21 Nov. 2012) from the Dell website ( for my French installation). This might be a first important point.
    After all this updating process, I ran the C: drive disk scan & defrag windows utilies to get prepared for partition shrinking.

    Secondly, the installation. I followed the instructions from the UEFI ubuntu help page (, so I used Ubuntu secured remix 12.10 64bit.
    At first, I burned a DVD, but it seems that it was not recognized as a bootable UEFI drive - I am not quite sure, because I tried the DVD in legacy mode at first (worked fine, but windows was therefore unbootable), and afterwards unsuccessfully in UEFI mode but I did not insist. DVD is so slow compared to USB, so I prepared a bootable USB key from windows with Linux Live USB Creator.
    In the Bios, I selected the UEFI + activated secure boot option, and booted the USB key. When booting, pressing F12 provides a list where the USB key is indeed recognized. I launched it, then choosed "try ubuntu".

    I the "trial" desktop, I used GParted to shrink the big windows partition to ~60Go, and made two new ones : 1) swap, and 2) a 50 Go ext4 to be mounted on / (I keep all the rest for data). I did not create any efi partition, although I was a bit confused by the documentation on that point (
    Then, "install ubuntu", choosed "something else" to set up partitioning by myself, then choosed the previously mentioned for swap and / ; and the install went through.
    After install, I rebooted, just to see what happens; the boot went fine, but as I expected, the windows partition was made unaccessible. So I ran boot-repair, choosed the "recommended repair", and now it works fine: the computer boots on grub, letting me choose win or ubuntu.

    For information: I did not run any extensive test so far, but at first glance ubuntu runs fine on this computer except the video card (damn hybrid Intel / AMD Radeon HD 7650, only the intel part works so far!), but this is not the place to talk about that.

    Hope this might help, and do not hesitate to ask for further information if needed.

  2. #52
    Join Date
    Oct 2007
    Kalama, WA
    Ubuntu 9.04 Jaunty Jackalope

    Re: No EFI boot on Dell Inspiron One 2330

    Quote Originally Posted by mouling View Post
    BIOS upgrade to version A09
    That did the trick! When I first had trouble, I checked for available updates, but there were none. I hadn't thought to check since, and this one was published a few days later.

    I upgraded the BIOS from A05 to A09, and everything works as advertised! I am able to boot the LiveCD/USB in UEFI mode. I used boot-repair to convert my MBR-mode install to UEFI, and it works fine -- secure-mode and unsigned versions.

    Thanks for sharing your successful experience, and thanks to Yann and everyone else who worked on this.

    Slightly off-topic note regarding the remix CD: While I could convert the standard Ubuntu 12.10 desktop image to USB, when I run Ubuntu 11.04's "Startup Disk Creator" on ubuntu-secure-remix-12.10-64bits.iso it instantly says "Installation Failed".

  3. #53
    Join Date
    Jul 2008

    Re: No EFI boot on Dell Inspiron One 2330

    I wish they would spread the info about what they did in the bios that made it work. I am having the same symptoms on a MSI GT70-0ND laptop (a Windows 8 UEFI model).

Page 6 of 6 FirstFirst ... 456


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts