Please setup your firmware to Legacy mode, then boot you Ubuntu liveCD, choose "Try Ubuntu", open a terminal and type:
sudo mount /dev/sda1 /mnt
then open a file browser, and make a backup of the /mnt/efi folder (eg to a USB key).

then type:
sudo rm -r /mnt/EFI/ubuntu
if you confirm that EFI/Boot/bootx64.efi is a copy of EFI/ubuntu/shimx64.efi, please also type:

sudo rm /mnt/EFI/Boot/bootx64.efi /mnt/EFI/Boot/bootmgfw.efi.bkp

Then run Boot-Repair --> Advanced options --> "GRUB location" tab --> tick "Separate /boot/efi partition: sda1" --> "GRUB options" tab --> untick "SecureBoot" --> tick "Purge GRUB and reinstall it" --> Apply (don't change any other option)
Indicate the new URL that will appear.
Setup the firmware in UEFI (non-Secure) mode.
Reboot the pc, and indicate what you observe.