Another update in case anyone is still reading this.

Before installing Ubuntu on this machine I took a full image of the disk as it was when I got the machine - when everything worked. Today I restored the image and what do I find?

Ubuntu's Uefi boot system has locked me out of the bios in Windows as well! Pressing f2 in windows now ,takes you to the windows boot menu not the bios. I also find out the another user posted an almost identical topic 2 weeks ago:

Same machine, same bios, same problem. He claims to have fixed it by 'reinstalling' the bios although he fails to explain how.

Whilst I have been in windows today I flashed the bios with the latest update. It makes no difference because I can't access it.

This is pretty obviously a problem with Ubuntu's implementation of Uefi which is preventing any bios access, similar to having a bios password - which I have never used.

Presenting someone with a machine that doesn't boot is one thing - you can always try another distro, but permanently locking somebody out of their own hardware is a different matter altogether. I now have a £450 laptop that is one day old, worked perfectly when I got it, but is now bordering on useless and surprise, surprise, I am not best pleased about it. I hope that is not being unreasonable.