Results 1 to 4 of 4

Thread: ./configure parameter

  1. #1
    Join Date
    Apr 2010

    Unhappy ./configure parameter

    Firstly apologies if this is a simple proble, I hope it is!
    I'm a newbie to linux so forgive me.

    I'm trying to install a package and having problems with one of the dependant libraries.

    Firstly, on typing './configure' all goes well until the end when it reports:


    'checking for OpenSSL library (libcrypto.a)... Not found

    OpenSSL not found'
    Use --with-openssl option to fix this problem'


    SO after checking I definately have OpenSSL installed I type:

    'sudo locate libcrypto.a'

    which returns:

    which gives: '/usr/lib/i386-linux-gnu/libcrypto.a'

    Easy eh?

    SO I then type:

    'sudo ./configure --with-openssl=/usr/lib/i386-linux-gnu'
    (as per the help file)

    BUT STILL I get:

    'OpenSSL not found
    Use --with-openssl option to fix this problem'

    No matter what I do its still the same.

    PLEASE tell me its a simple syntax error.

    Id appreciate any suggestions..

  2. #2
    Join Date
    Jul 2007
    Magic City of the Plains
    Xubuntu 16.10 Yakkety Yak

    Re: ./configure parameter HELP!

    Moved to Packaging and Compiling Programs.

    You're probably missing libssl-dev, and possible another -dev package as well. What are you trying to compile? Have you checked the repositories for the program?

  3. #3
    Join Date
    Apr 2010

    Re: ./configure parameter HELP!

    Many thanks for the reply.
    Yes you were correct on both accounts.

    It did need libssl-dev and it was indeed available in a repository anyway.

    It was a trustedQSL program, a log signing program for radio hams.

    Again thanks..

  4. #4
    Join Date
    Oct 2009
    Reykjavík, Ísland
    Lubuntu 16.10 Yakkety Yak

    Re: ./configure parameter

    Good, then please mark the thread 'solved'.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts