Results 1 to 6 of 6

Thread: Win7 does not boot after 12.10 dual boot installation

  1. #1
    Join Date
    Nov 2012
    Beans
    10

    Win7 does not boot after 12.10 dual boot installation

    Hi all,

    I'm new to Ubuntu and I've installed Ubuntu desktop 12.10 in my Satellite L300D, alongside with Win7.
    While the Ubuntu installation seems to be just fine, I can't boot Win7.
    When I choose the "Windows 7 (loader) (on /dev/sda2)" it changes to a black screen for 1 second and then it returns to GRUB.

    I've tried the Boot Repair solution but it didn't work. This is my Boot Info:
    http://paste.ubuntu.com/1371004/

    Can you please help me?
    Please tell me if you need further information about my settings.

    Thanks and regards!

  2. #2
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,779
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Win7 does not boot after 12.10 dual boot installation

    You have grub2 installed also on the windows partition /dev/sda2. I don't know whether you put it there, or it installed itself, because it shouldn't do that.
    In any case, windows can't load with grub2 there.

    You can use a testdisk procedure to recover the backup sector of the partition, (like BackupBS). You can use testdisk from your ubuntu or from ubuntu live mode. You only need to download it and run it depending in which folder you extract it.

    http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

    That tutorial is also for recovering partitions, which you don't need. Focus only on the instructions to recover the partition boot sector towards the middle-end of the page.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  3. #3
    Join Date
    Nov 2012
    Beans
    10

    Re: Win7 does not boot after 12.10 dual boot installation

    Thanks for your help Darko.

    I used the option "Install Ubuntu alongside Windows 7" so I don't how grub2 got installed there.
    I'm quite new to Ubuntu so, you're saying that I've two grub2 installed?
    I should use TestDisk to repair my /dev/sda2 partition and grub2 will still work after that?

    Later today I will try to run the "NTFS Boot sector recovery" tutorial section.

    Thanks a lot once again

  4. #4
    Join Date
    Nov 2009
    Location
    Mataro, Spain
    Beans
    13,779
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Win7 does not boot after 12.10 dual boot installation

    Correct, you have the main grub2 on the MBR of the disk, which is only /dev/sda and it's where it should be. It will work after the repair.

    You also have grub2 on the boot sector of the partition /dev/sda2, which shouldn't be there. That is what needs fixing.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  5. #5
    Join Date
    Nov 2012
    Beans
    10

    Re: Win7 does not boot after 12.10 dual boot installation

    Ok, thanks a lot.
    I'll reply with the fixing results later on.
    Cheers

  6. #6
    Join Date
    Nov 2012
    Beans
    10

    Re: Win7 does not boot after 12.10 dual boot installation

    It worked! Thanks once again.
    Cheers!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •