Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: Mounting NDAS device

  1. #1
    Join Date
    May 2012
    Beans
    44

    Mounting NDAS device

    First of all let me tell you that I'm Linux-ignorant, I've just started using Ubuntu 12.04.
    I've a Freecom II hardwired to the router (thomsonTG585 v7) hardwired to the pc that I can access from XP using the ximeta drivers. When I login to Ubuntu it doesn't appear in my network, windows network, workgroup whereas I'm able to see and act on my wife laptop. I've read a lot of posts (most of them are too complex for my knowledge of linux) and found this workaround on the net, but it isn't working for me
    This is what I've done

    installed smbfs

    1) sudo apt-get install smbfs

    created the directory

    2) sudo mkdir /media/freecom

    edited the nsswitch.conf

    3) sudo nano /etc/nsswitch.conf

    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

    modified as

    hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

    installed winbind

    4) sudo apt-get install winbind

    granted the permission to read and write

    5) sudo nano /root/.smbcredentials

    added these 2 rows:

    username=marco
    password=*****

    6) sudo chmod 700 /root/.smbcredentials

    then

    7) sudo mount -a

    nothing happend. I'm missing somenthing?
    Last edited by Toporagno; May 20th, 2012 at 04:11 PM. Reason: Changed the title from NAS to NDAS

  2. #2
    Join Date
    Mar 2011
    Location
    the Netherlands
    Beans
    397
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Need help mounting NAS device

    There is a pretty good manual here that will make your NAS automount. via "Network" you should be able to access your NAS as well, but that is not as handy as automounting.


    about your actions:
    I think you are making it more complicated than necessary; just installing smbfs, creating the fstab entry (see manual) and making the .cifscredentials file should do, of course you need a mount point, but you can create a folder in your home directory and link to that from the fstab file
    ----------------------------------------------------------------------------------------------------
    3) sudo nano /etc/nsswitch.conf

    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

    modified as

    hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

    installed winbind

    4) sudo apt-get install winbind

    granted the permission to read and write

    5) sudo nano /root/.smbcredentials

    added these 2 rows:

    username=marco
    password=*****

    6) sudo chmod 700 /root/.smbcredentials

    then

    7) sudo mount -a

    ------------------------------------------------------------------------------------------------------
    Attached Images Attached Images
    Last edited by Jacobonbuntu; May 15th, 2012 at 09:31 PM.

  3. #3
    Join Date
    Feb 2008
    Beans
    5,003
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Need help mounting NAS device

    Truly, I can't figure out what you are trying to say: "I've a Freecom II hardwired to the router (thomsonTG585 v7) hardwired to the pc that I can access from XP using the ximeta drivers."

  4. #4
    Join Date
    May 2012
    Beans
    44

    Re: Need help mounting NAS device

    Quote Originally Posted by gordintoronto View Post
    Truly, I can't figure out what you are trying to say: "I've a Freecom II hardwired to the router (thomsonTG585 v7) hardwired to the pc that I can access from XP using the ximeta drivers."
    Hi gordintoronto, what I was trying to say is that I have a wired connection to the router and the NAS is also wired to the router. Sorry, English is not my first language.

  5. #5
    Join Date
    May 2012
    Beans
    44

    Re: Need help mounting NAS device

    Hi Jacobonbuntu, thanks for your reply and the link, it is very easy to read and follow.
    I've just a couple of questions:
    the guide says "Add the following line to the bottom of the file: //192.168.0.10/SHARENAME /media/Storage cifs auto,iocharset=utf8,uid=USER,gid=users,credentials =/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0


    You have to change the following information:

    Change 192.168.0.10 to the IP address or DNS name of your server
    (is this the ip address of the router? because when I launch ipconfig in windows I don't see an ip address for the NAS. Can I use the device ID instead which will be U30V8-DGH7C-M0E2G-***** or the mac address?)

    Change SHARENAME to the share you want to mount
    (is this the name of the NAS device as I see it in windows? If yes then how I've to write it because in windows it appears as NDAS Device 1 in the NDAS management and as Freecom Classic SL in my computer)
    Thanks for your help
    Last edited by Toporagno; May 16th, 2012 at 03:47 PM.

  6. #6
    Join Date
    Mar 2011
    Location
    the Netherlands
    Beans
    397
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Need help mounting NAS device

    Quote Originally Posted by Toporagno View Post
    Hi jocobubuntu, thanks for your reply and the link, it is very easy to read and follow.
    I've just a couple of questions:
    the guide says "Add the following line to the bottom of the file: //192.168.0.10/SHARENAME /media/Storage cifs auto,iocharset=utf8,uid=USER,gid=users,credentials =/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0


    You have to change the following information:

    Change 192.168.0.10 to the IP address or DNS name of your server
    (is this the ip address of the router? because when I launch ipconfig in windows I don't see an ip address for the NAS. Can I use the device ID instead which will be U30V8-DGH7C-M0E2G-***** or the mac address?)

    Change SHARENAME to the share you want to mount
    (is this the name of the NAS device as I see it in windows? If yes then how I've to write it because in windows it appears as NDAS Device 1 in the NDAS management and as Freecom Classic SL in my computer)
    Thanks for your help
    Hi Toporagno,

    you can find out the ip address with netdiscover; open a terminal and type "netdiscover". It will not be installed by default, but the terminal will offer you to do that for you. once installed type again "netdiscover and you will see a list of devices, connected to the network, and their ip addresses.
    The share name is usually the shared folder name. as an example, this is the line in my fstab file for the folder "werkmap_documenten" on my LG NAS. (The \040 is the way to deal with spaces):

    //192.168.0.103/werkmap_documenten/documenten\040Jacob /home/jacob/Netwerkmap cifs auto,iocharset=utf8,uid=jacob,gid=users,credential s=/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0

  7. #7
    Join Date
    May 2012
    Beans
    44

    Re: Need help mounting NAS device

    Hello Jacobonbuntu,
    I've installed and launched netdiscover as suggested, it took quite a while to perform (~6 hours) and this is the result:

    Currently scanning: 10.255.253.0/8 | Screen View: Unique Hosts

    1415 Captured ARP Req/Rep packets, from 4 hosts. Total size: 84900
    __________________________________________________ ___________________________
    IP At MAC Address Count Len MAC Vendor
    -----------------------------------------------------------------------------
    192.168.1.254 08:76:ff:5f:**:** 1340 80400 Unknown vendor
    10.0.0.138 08:76:ff:5f:**:** 35 2100 Unknown vendor
    0.0.0.0 00:21:5d:79:**:** 14 840 Intel Corporate
    192.168.1.64 00:21:5d:79:**:** 26 1560 Intel Corporate
    *** glibc detected *** netdiscover: free(): invalid pointer: 0x08097120 ***
    --------------------------------------------------------------------------------------------------------------------

    The two ip address related to the mac address starting with 00: belong to my wife laptop.
    The mac address starting with 08: is the mac address of the router (the mac address of my NAS start with 00:01)
    I've tried both ip addresses but none works this is the line I've added at the bottom of fstab
    //192.168.1.254/Music /media/freecom cifs auto,iocharset=utf8,uid=marco,gid=users,credential s =/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0
    and when tried sudo mount -a I've received [mntent]: line 15 in /etc/fstab is bad

    I don't really know what to do...
    Last edited by Toporagno; May 16th, 2012 at 08:40 PM.

  8. #8
    Join Date
    Jul 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Need help mounting NAS device

    Quote Originally Posted by Toporagno View Post
    ...
    I don't really know what to do...
    The first thing you should do is REMOVE all the references to wins and winbind (e.g return the system back to its default settings).

    There is no need to use winbind on a non Active Directory system. It's really for mapping Linux users with Windows AD attributes.

    The wins reference in nsswitch.conf has nothing to do with winbind. WINS is to store the NETBIOS names for multiple subnet situations. Samba recommends NOT using a WINS server in a simple 1 subnet network. Remove the wins listing in the nsswitch.conf file.

    Do you have a Samba user defined on the NAS?

    Once these are done we can see what else you need to allow you access to your NAS.

  9. #9
    Join Date
    May 2012
    Beans
    44

    Re: Need help mounting NAS device

    Hi Redmk2 thanks for stopping by and helping.

    I've removed windbind with sudo apt-get remove winbind and removed the wins listing in the nsswitch.conf file.

    Please bear with me, as I said I'm totally new to linux, what you mean by "Do you have a Samba user defined on the NAS?".

  10. #10
    Join Date
    Feb 2008
    Beans
    5,003
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Need help mounting NAS device

    The command: arp -a
    should list the IP adresses of everything on your network, in a few seconds.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •