Results 1 to 3 of 3

Thread: Broken windows MBR after attempted restore.

  1. #1
    Join Date
    Feb 2013

    Angry Broken windows MBR after attempted restore.

    Hey all, I recently installed ubuntu onto a memory stick, thinking it would work the same way as the liveUSB. But however it did not run directly from the USB as the live version did, if I tried to it wouldn't find the operating system and would default back to the hard drive and I would select ubuntu in the windows boot manager which would run grub on the USB.
    This was fine until I didn't want my hard drive to ask to boot Ubuntu anymore, so I followed some online advice to rest the windows MBR, and not much changed, except now when I select windows or Ubuntu from the MBR screen it cannot find either.
    I could change the USB with Ubuntu back into a liveUSB and then I would at least have some access back to my computer, but can someone recommend an actual method as to reseting windows 7 MBR through ubuntu?
    Last edited by BTORogers; February 13th, 2013 at 07:55 PM.

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Broken windows MBR after attempted restore.

    Did you install wubi to flash drive?

    Best to see details, and this may fix issues.

    Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
    Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Feb 2013

    Re: Broken windows MBR after attempted restore.

    NVM, I fixed it by recovering from the windows 7 install disk. It still shows the MBR GUI on startup, but I guess that is more of a windows problem.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts