Results 1 to 3 of 3

Thread: Printer Problem

Hybrid View

  1. #1
    Join Date
    Aug 2008

    [SOLVED] Printer Problem

    Hi, I have a problem in Lubuntu with a new printer a just bought. I tried to set it up and couldn't make it to work.
    Brand new, HP Deskjet 1000 Printer J110 Series.
    According to documentation on Ubuntu website, this printer is compatible, so I followed instructions on link, had to download HPLIP, latest version ( to Desktop, and then on terminal cd to Desktop, then run this command:
    I followed the instructions, there was a dependency problem that since I chose automatic install on terminal I was able to solve but had to choose software for Ubuntu 12.04 since 12.10 (i got Lubuntu 12.10) isn't supported, so I just typed 'y' for yes to this suggestion.
    Then a GUI software came up where I just finished install, requested restart since I had the printer plugged in through USB cable, and then finally I run command:
    'hp-setup' and though I have the software it doesn't print anything, this is what I the terminal gave:

    QGtkStyle was unable to detect the current GTK+ theme.
    Searching... (bus=usb, search=(None), desc=0)
    \WARNING: gnome-keyring:: couldn't connect to: /run/user/kaliman/keyring-m8clIX/pkcs11: No such file or directory
    WARNING: gnome-keyring:: couldn't connect to: /run/user/kaliman/keyring-m8clIX/pkcs11: No such file or directory

    Please help, I need to get the printer to work.
    Last edited by mentisafer; November 19th, 2012 at 01:08 AM.

  2. #2
    Join Date
    May 2010

    Re: Printer Problem

    It seems an old bug titled
    "XFCE (and other non-GNOME) desktops do not initialise gnome-keyring correctly / WARNING: gnome-keyring:: couldn't connect to PKCS11"

    Use an Ubuntu Live-CD to install the drivers and test the printer, if this works install it as a temporarily solution to get the printer working until developers correct this bug.

    [ ]'s

  3. #3
    Join Date
    Aug 2008

    Re: Printer Problem

    thanks! i just installed Ubuntu and it worked right away, I dint even need to set up anything, great.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts