Results 1 to 4 of 4

Thread: My GLXGears never sounds impressive!

  1. #1
    Join Date
    Dec 2008
    Location
    UK
    Beans
    150
    Distro
    Ubuntu 15.04 Vivid Vervet

    My GLXGears never sounds impressive!

    Hello

    For years, on various machines, I have watched other people posing their output from glxgears FPS and I am left astonished since mine is never even close to that!

    I now have a beast of a machine (quad core ivy bridge i7@3.4GHz, 16GB RAM) and I have just put a graphics card in - not the best, but still pretty good - GeForce 210 1GB. After *finally* getting the nvidia drivers working on 12.10, my lxgears gives around 60 frames per second.

    I know glxgears isn't a good benchmark but I would just, for once, love to see the "thousands" of FPS other users see. I think the problem is it running synchronised to the monitor refresh, but

    Code:
    export vblank_mode=0
    glxgears
    had no effect on the FPS. Also, I get an error
    Code:
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    294 frames in 5.0 seconds = 58.659 FPS
    300 frames in 5.0 seconds = 59.999 FPS
    300 frames in 5.0 seconds = 60.000 FPS
    299 frames in 5.0 seconds = 59.792 FPS
    301 frames in 5.0 seconds = 60.008 FPS
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
          after 50 requests (50 known processed) with 0 events remaining.
    Any ideas?
    Ubuntu 14.04

  2. #2
    Join Date
    Jan 2011
    Beans
    1,151

    Re: My GLXGears never sounds impressive!

    Quote Originally Posted by tornadof3 View Post
    Hello

    For years, on various machines, I have watched other people posing their output from glxgears FPS and I am left astonished since mine is never even close to that!

    I now have a beast of a machine (quad core ivy bridge i7@3.4GHz, 16GB RAM) and I have just put a graphics card in - not the best, but still pretty good - GeForce 210 1GB. After *finally* getting the nvidia drivers working on 12.10, my lxgears gives around 60 frames per second.

    I know glxgears isn't a good benchmark but I would just, for once, love to see the "thousands" of FPS other users see. I think the problem is it running synchronised to the monitor refresh, but

    Code:
    export vblank_mode=0
    glxgears
    had no effect on the FPS. Also, I get an error
    Code:
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    294 frames in 5.0 seconds = 58.659 FPS
    300 frames in 5.0 seconds = 59.999 FPS
    300 frames in 5.0 seconds = 60.000 FPS
    299 frames in 5.0 seconds = 59.792 FPS
    301 frames in 5.0 seconds = 60.008 FPS
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
          after 50 requests (50 known processed) with 0 events remaining.
    Any ideas?
    some people glxgears are capped at 60fps
    (\ /)
    (O.o)
    (> <)
    This is Bunny. Copy Bunny into your signature to help him on his way to world domination.

  3. #3
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: My GLXGears never sounds impressive!

    It's not a good benchmark, but if you still want to, you'll want to disable the "sync to vblank" option in your Nvidia settings dialog.

    Sync to VBlank just syncs your graphics card's redraw to the monitor refresh, so you'll get capped at around 60 fps.

  4. #4
    Join Date
    Dec 2008
    Location
    UK
    Beans
    150
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: My GLXGears never sounds impressive!

    Thank you sir! That did it ... now getting around 1800+ FPS on a 1920x1080 display. Thanking you kindly!
    Ubuntu 14.04

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •