Results 1 to 4 of 4

Thread: Lost virtual machines

  1. #1
    Join Date
    Apr 2013

    Lost virtual machines

    In Virtualbox I have recently got this error message. All hard drives and external media are mounted and I still get this message. Why?

    One or more virtual hard disks, CD/DVD or floppy media are not currently accessible. As a result, you will not be able to operate virtual machines that use these media until they become accessible later.

    Press Check to open the Virtual Media Manager window and see what media are inaccessible, or press Ignore to ignore this message.

  2. #2
    Join Date
    Mar 2010
    Lubuntu 14.04 Trusty Tahr

    Re: Lost virtual machines

    Quote Originally Posted by gnugen View Post
    In Virtualbox I have recently got this error message. All hard drives and external media are mounted and I still get this message. Why?
    I've only seen this message when
    a) the file system isn't mounted
    b) the file system is mounted read-only
    c) the virtualbox config file is corrupt
    d) the files ownership/permissions have been changed

    So, those are the places that I'd start my research.
    Being "mounted" is NOT the same as "viewing in Nautilus."

    Anyway, check those things and check the log files in /var/log/ for extra information.

  3. #3
    Join Date
    Jul 2006
    South Africa
    Ubuntu 15.04 Vivid Vervet

    Re: Lost virtual machines

    I too am having problems.
    I look at TheFu's list of points and he says Being "mounted" is NOT the same as "viewing in Nautilus."
    That throws me completely and now I don't understand points a and b like I thought I did.
    It is very unlikely that an upgrade process is going to change the ownership / permissions, which leaves the possibility of some "corruption" (incompatibility) of the configuration. To handle that, I moved the .vdi file to another folder and deleted the Vitrualbox VMs directory that used to contain it.

    Next I went looking for a release on the Oracle website. They don't have a 13.04 version. That means we are trying to make the older one work with an unsupported kernel. To recompile the kernel, we need the correct header files and they don't exist. Unless someone actually knows better and can tell us what to do, I guess we now have to be patient and wait for Oracle to catch up with this release.

    Next I went to the Ubuntu Software Center and installed their version of VirtualBox. As I understand it, this is the OSE version (which I guess probably means something like Open Source Edition) - I read somewhere in the forums that Oracle don't support it.

    I started this version and created a new virtual machine without a hard drive. This recreated the directory that I had earlier deleted and I moved the .vdi file into it. Finally, under the settings for my new virtual machine, I added an exisiting hard drive and pointed it to the .vdi file.

    Now it all is well in the jungle!!

    Last edited by gwm; April 28th, 2013 at 10:52 PM.

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012

    Re: Lost virtual machines

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts