I did a fresh install of 12.10 but cannot boot into it now. I tried boot-repair a couple of time but without success.

From my BIOS, I tried booting into both "ubuntu" and "WD ..." (my primary hdd) but both give me the black screen with cursor.

The current state of my installation as given by boot-repair is here: http://paste.ubuntu.com/1358166/

Last time I ran boot-repair I installed GRUB install devices into:

This was last output on command line:

Creating config file /etc/default/grub with new version
Installation finished. No error reported.
/usr/sbin/grub-bios-setup: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
/usr/sbin/grub-bios-setup: warning: Embedding is not possible.  GRUB can  only be installed in this setup by using blocklists.  However,  blocklists are UNRELIABLE and their use is discouraged..
Installation finished. No error reported.
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-17-generic
Found initrd image: /boot/initrd.img-3.5.0-17-generic
Anyone knows what is wrong? Any help is much appreciated,