Hi folks,

I have an ASUS 1000hg running 12.04LTS Ubuntu. I have had problems with the 'Suspend' function which I use regularly with the occasional reboot. Three times now my pc has not come back from being put into Suspend. On the two previous occasions removing the battery and replacing it got the machine back but, last night the pc would not return. I tried the usual remove and replace battery, then the reset switch on the bottom of the pc and running from mains without the battery installed, but nothing brought it back to life. When the pc is in the "Crashed Suspend" you get the power lights on but nothing else so I left it in this state overnight. This morning the power lights were off so I tried to turn it on but it was dead. so removed the battery and tried with mains on and the machine booted up. I must say that I have very rarely run the machine from the mains in the past, it's always been run from the battery and this looks like it could be battery related, but the machine is only 2 years old.

Has any body else experienced problems with suspend?
Any helps and advice is much appreciated,