Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 42

Thread: Can't get ndiswrapper to work with Network Manager

  1. #11
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get ndiswrapper to work with Network Manager

    This reinstalled the firmware into the /lib/firmware/b43legacy folder, and also installed the /lib/firmware/b43 folder with all its firmware. I rebooted, but still no wireless networks showed up. This is understandable, because I now had a mix of b43legacy and ndiswrapper.
    Unload Ndiswrapper and load b43/b43-legacy

    Code:
    sudo modprobe -rfv ndiswrapper
    sudo modprobe ssb b43legacy
    iwconfig
    dmesg | egrep 'b43|Firm'

  2. #12
    Join Date
    Aug 2007
    Beans
    584
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't get ndiswrapper to work with Network Manager

    Flash63

    Here is the output you requested. Because I had made other mods to the system I installed yesterday, I installed still another OS into a new disk partition. I will use this partition exclusively for changes you ask for.
    Code:
    ralph@ralph-Presario-2100-DM728A:~$ sudo modprobe -rfv ndiswrapper
    [sudo] password for ralph: 
    FATAL: Module ndiswrapper not found.
    ralph@ralph-Presario-2100-DM728A:~$ sudo modprobe ssb b43legacy
    ralph@ralph-Presario-2100-DM728A:~$ iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    eth0      no wireless extensions.
    
    ralph@ralph-Presario-2100-DM728A:~$ dmesg | egrep 'b43|Firm'
    [    3.311166] b43-pci-bridge 0000:00:09.0: PCI INT A -> Link[LNKD] -> GSI 10 (level, low) -> IRQ 10
    [    9.818425] b43legacy-phy0: Broadcom 4306 WLAN found (core revision 4)
    [    9.866158] b43legacy-phy0 debug: Found PHY: Analog 1, Type 2, Revision 1
    [    9.866181] b43legacy-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
    [    9.893261] b43legacy-phy0 debug: Radio initialized
    [   17.278669] b43legacy-phy0 ERROR: Firmware file "b43legacy/ucode4.fw" not found or load failed.
    [   17.278681] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the correct firmware (version 3).
    [ 7754.884125] b43legacy-phy0: Loading firmware version 0x127, patch level 14 (2005-04-18 02:36:27)
    [ 7754.948657] b43legacy-phy0 debug: Chip initialized
    [ 7754.949202] b43legacy-phy0 debug: 30-bit DMA initialized
    [ 7754.951208] Registered led device: b43legacy-phy0::radio
    [ 7754.951261] b43legacy-phy0 debug: Wireless interface started
    [ 7754.964482] b43legacy-phy0 debug: Adding Interface type 2
    ralph@ralph-Presario-2100-DM728A:~$
    Just a note. The wireless came up and ran fine as soon as I installed firmware-b43-installer. However, it kept dropping out and resyncing so it was not useful.

    Thanks for your help
    Ralph

  3. #13
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Can't get ndiswrapper to work with Network Manager

    You actually need firmware-b43-installer and b43-fwcutter which has largely superseded ndiswrapper.

    If that is going to work, you won't find out with ndiswrapper installed. Gets in the way. Chilli555 can probably add to this.

  4. #14
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get ndiswrapper to work with Network Manager

    The Firmware-File ucode4.fw is still missing:
    Code:
    [   17.278669] b43legacy-phy0 ERROR: Firmware file "b43legacy/ucode4.fw" not found or load failed.
    The wireless came up and ran fine as soon as I installed firmware-b43-installer.
    Check again:
    Code:
    dmesg | egrep 'b43|Firm'
    If the same error occurs, install the older Firmware-Package as formerly described. ucode4.fw for this older device was not included into the official Firmware-Packages.

    Now uninstall Ndiswrapper completely.
    Last edited by flash63; November 20th, 2012 at 07:34 AM.

  5. #15
    Join Date
    Aug 2007
    Beans
    584
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't get ndiswrapper to work with Network Manager

    Flash63

    I did as you said on the clean install. I still got the same error about about the firmware. See below.

    Code:
    wget http://media.cdn.ubuntu-de.org/forum/attachments/04/32/2480236-Broadcom_Firmware.tar.gz 
    sudo tar xvf 2480236-Broadcom_Firmware.tar.gz -C /lib/firmware/
    Code:
    ralph@ralph-Presario-2100-DM728A:~$ dmesg | egrep 'b4|Firm'
    [    3.311166] b43-pci-bridge 0000:00:09.0: PCI INT A -> Link[LNKD] -> GSI 10 (level, low) -> IRQ 10
    [    9.818425] b43legacy-phy0: Broadcom 4306 WLAN found (core revision 4)
    [    9.866158] b43legacy-phy0 debug: Found PHY: Analog 1, Type 2, Revision 1
    [    9.866181] b43legacy-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2
    [    9.893261] b43legacy-phy0 debug: Radio initialized
    C
    [ 7754.884125] b43legacy-phy0: Loading firmware version 0x127, patch level 14 (2005-04-18 02:36:27)
    [ 7754.948657] b43legacy-phy0 debug: Chip initialized
    [ 7754.949202] b43legacy-phy0 debug: 30-bit DMA initialized
    [ 7754.951208] Registered led device: b43legacy-phy0::radio
    [ 7754.951261] b43legacy-phy0 debug: Wireless interface started
    [ 7754.964482] b43legacy-phy0 debug: Adding Interface type 2
    [ 9113.427823] b43legacy-phy0 debug: Removing Interface type 2
    [ 9113.432203] b43legacy-phy0 debug: Wireless interface stopped
    [ 9113.440532] b43legacy-phy0 debug: DMA-30 0x0260 (RX) max used slots: 14/64
    [ 9113.440651] b43legacy-phy0 debug: DMA-30 0x0200 (RX) max used slots: 7/64
    [ 9113.440752] b43legacy-phy0 debug: DMA-30 0x02A0 (TX) max used slots: 0/128
    [ 9113.448145] b43legacy-phy0 debug: DMA-30 0x0280 (TX) max used slots: 0/128
    [ 9113.456121] b43legacy-phy0 debug: DMA-30 0x0260 (TX) max used slots: 0/128
    [ 9113.464177] b43legacy-phy0 debug: DMA-30 0x0240 (TX) max used slots: 0/128
    [ 9113.472042] b43legacy-phy0 debug: DMA-30 0x0220 (TX) max used slots: 28/128
    [ 9113.480041] b43legacy-phy0 debug: DMA-30 0x0200 (TX) max used slots: 0/128
    [ 9113.488045] b43legacy-phy0 debug: Radio initialized
    [ 9113.488059] b43legacy-phy0 debug: Radio initialized
    [50494.140100] b43legacy-phy0: Loading firmware version 0x127, patch level 14 (2005-04-18 02:36:27)
    [50494.204623] b43legacy-phy0 debug: Chip initialized
    [50494.205492] b43legacy-phy0 debug: 30-bit DMA initialized
    [50494.211219] Registered led device: b43legacy-phy0::radio
    [50494.211307] b43legacy-phy0 debug: Wireless interface started
    [50494.217490] b43legacy-phy0 debug: Adding Interface type 2
    ralph@ralph-Presario-2100-DM728A:~$
    Thanks for taking so much time.

  6. #16
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get ndiswrapper to work with Network Manager

    Hello,
    there occurs no more errors. Everything seems to be right now.

    previous message was
    Code:
    [   17.278669] b43legacy-phy0 ERROR: Firmware file "b43legacy/ucode4.fw" not found or load failed.

  7. #17
    Join Date
    Aug 2007
    Beans
    584
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Can't get ndiswrapper to work with Network Manager

    I'm not sure what you mean. Doesn't the big ERROR message still mean that I have an error?

    Anyway, it still doesn't work. It just connects for a few seconds and then drops out. This is what it has been doing consistently, since I first tried to use b43legacy and b43. Neither has been able to maintain a connection. The system is unuseable.

    Ralph

  8. #18
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Can't get ndiswrapper to work with Network Manager

    Are you 110% positive you have totally removed ndiswrapper?

  9. #19
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't get ndiswrapper to work with Network Manager

    Quote Originally Posted by Ralph L View Post
    Anyway, it still doesn't work. It just connects for a few seconds and then drops out. This is what it has been doing consistently, since I first tried to use b43legacy and b43. Neither has been able to maintain a connection. The system is unuseable.
    I see that you are already being helped by the best people here, so just to help making the current picture a bit more clearer, please run and post the result of 'wireless_script' as suggested here : http://ubuntuforums.org/showpost.php?p=12350385

    It should be able to give us all (or most) of the info we are interested in.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  10. #20
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't get ndiswrapper to work with Network Manager

    Hello,
    please use additionally the following Terminal-Commands for a better diagnosis after the connection was lost.

    filter out your syslog and interface-settings:
    Code:
    egrep 'Net|b43|Firm|reason' /var/log/syslog
    ifconfig
    iwconfig
    Basic Wireless Settings of your Wireless Router:
    * use only safe WPA2-AES Encryption, no mixed-Modes like WPA1/2 or WPA2-TKIP!
    * find a free radio-channel, don't use „Auto“ Konfiguration. For that, check other WLAN Access-Points in your neighbourhood:
    Code:
    sudo iwlist scan

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •