Results 1 to 4 of 4

Thread: Need help for ATI display driver in Precise(12.04)

  1. #1
    Join Date
    Nov 2012
    Beans
    5

    Question Need help for ATI display driver in Precise(12.04)

    Hello there,

    So I'm trying to make a very ancient laptop (Fujitsu Siemens Amilo M1425) make it recognize its own video card but its turning up more complicated than I've expected.

    It has an ATI Mobility Radeon 9700 under the hood, and the instructions here seemed to fit my purposes. However, at a certain step I came across this error and have no idea how to move forward. Any help is appreciated, I'm quite the linux newbie

    sudo dpkg -i fglrx*.deb
    (Reading database ... 191028 files and directories currently installed.)
    Preparing to replace fglrx-amdcccle 2:8.831-0ubuntu1 (using fglrx-amdcccle_8.831-0ubuntu1_i386.deb) ...
    Unpacking replacement fglrx-amdcccle ...
    Preparing to replace fglrx-dev 2:8.831-0ubuntu1 (using fglrx-dev_8.831-0ubuntu1_i386.deb) ...
    Unpacking replacement fglrx-dev ...
    Preparing to replace fglrx 2:8.831-0ubuntu1 (using fglrx_8.831-0ubuntu1_i386.deb) ...
    Unpacking replacement fglrx ...
    dpkg: dependency problems prevent configuration of fglrx:
    fglrx depends on dkms; however:
    Package dkms is not installed.
    dpkg: error processing fglrx (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of fglrx-amdcccle:
    fglrx-amdcccle depends on fglrx; however:
    Package fglrx is not configured yet.
    dpkg: error processing fglrx-amdcccle (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of fglrx-dev:
    fglrx-dev depends on fglrx; however:
    Package fglrx is not configured yet.
    dpkg: error processing fglrx-dev (--install):
    dependency problems - leaving unconfigured
    Processing triggers for ureadahead ...
    Processing triggers for man-db ...
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    Errors were encountered while processing:
    fglrx
    fglrx-amdcccle
    fglrx-dev
    Last edited by heml0ck; November 12th, 2012 at 09:17 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,504
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Need help for ATI display driver in Precise(12.04)

    heml0ck; Hi ! Welcome to the forum.

    I see this:
    Unpacking replacement fglrx ...
    dpkg: dependency problems prevent configuration of fglrx:
    fglrx depends on dkms; however:
    Package dkms is not installed.
    dpkg: error processing fglrx (--install):
    Install "dkms":
    Code:
     apt-get install dkms
    and try to install the driver again; but do not be surprised if a proprietary driver does not run on "older" hardware/newer kernel .
    just try'n to help <== BDQ

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Need help for ATI display driver in Precise(12.04)

    Support for that chipset has been moved to a legacy driver branch and the legacy driver that supports it will not work with X Server versions post 2008.

    Short of downgrading X Server to a much older version, which will undoubtedly cause catastrophic breakage, you will not be able to use any method to get a proprietary ATI driver to work.

    You will have to stick with the open source Radeon driver used by default when you installed Ubuntu.
    The Left Coast Geek * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    Don't let the truth get in the way of a good story!
    This universe is crazy. I'm going back to my own.


  4. #4
    Join Date
    Nov 2012
    Beans
    5

    Re: Need help for ATI display driver in Precise(12.04)

    Thank you both for replies. The "dkms" option didn't solve it so I'll try again with Ubuntu 8.04

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •