Results 1 to 4 of 4

Thread: Can't watch videos in Ubuntu

  1. #1
    Join Date
    Jul 2011

    Can't watch videos in Ubuntu

    This is a problem I've been experiencing for a long time now. When I first got this Linux box from my brother, I could download a video file onto my computer and watch it just fine. Videos worked for a while, then suddenly one day when I tried to play a video file, there was no image, just a green screen (in the player) and the sound. I tried installing VLC player, hoping that would fix it, but I have the exact same problem in VLC. This has been going on for over a year now. I can stream videos just fine, but if I download the video I was just streaming, and try to play it from my HD, I have the same problem. If I put the file on a flash drive and play it on my girlfriend's Windows computer, it works just fine.

    When the problem first began, I tried installing a codec pack, thinking it might be a codec problem, but that didn't seem to change anything. I've updated VLC every time updates are released, still no fix. I'm totally at a loss here.

    I'm currently running Ubuntu 11.10, but I've had this problem since Ubuntu 10.10, across updates.

  2. #2
    Join Date
    Mar 2012
    Ubuntu 12.10 Quantal Quetzal

    Re: Can't watch videos in Ubuntu

    Have you installed all codec packs. Just search "gstreamer" in software center and install everything with "gstreamer".

    When did you do the last ubuntu software update?


  3. #3
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012

    Re: Can't watch videos in Ubuntu

    All I have for you is a general answer that may help.

    The restricted-extras are already prepackaged, no need to load them one at a time.

  4. #4
    Join Date
    Jul 2011

    Re: Can't watch videos in Ubuntu

    @ Halbblutplins:
    Four entries for gstreamer show up and all four are already installed.

    @ ibjsb4:
    I'm not sure what that link has to do with anything. My problem is not being able to capture video. My problem is being able PLAY the video once I have it on my HD. I can just download videos without having to capture them from a stream. Or, recently, I recorded some videos with my EVO 4G LTE and transfered them to my computer. But when I try to watch them on Linux, all I get is a pink screen in the player, and the sound from the video. When I watch them on a Windows computer, they play just fine.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts